i am having a problem with a newly installed fuel pump. now when i turn on the ignition i am not getting power to the fuel pump

Asked by Aug 12, 2012 at 11:44 AM about the 1986 Toyota Supra 2 dr Hatchback

Question type: Maintenance & Repair

2 Answers

55

well I would go back to your mechanic and have them make sure they hooked your wires back to the fuel pump correctly you probally have some bad connection somewhere

155

The fuel pump power wire connector is located just in front of the shifter. If you remove the center console, you should be able to check the connector and find out if it's getting power and if it's connected properly.

Your Answer

Add photo

Related Questions

Search Toyota Supra Questions

Toyota Supra Experts

#1 Stephen Sidman
Stephen Sidman
Reputation 70
#1 James Hayman
James Hayman
Reputation 70
#3 littlehorn
littlehorn
Reputation 50
View All

Related Models For Sale

Used Mazda RX-7
63 listings
Used Ford Mustang
454 Great Deals out of 45,522 listings starting at $1,999
Used Chevrolet Corvette
123 Great Deals out of 20,508 listings starting at $3,000
Used Chevrolet Camaro
205 Great Deals out of 30,790 listings starting at $1,217
Used BMW M3
41 Great Deals out of 1,542 listings starting at $5,800
Used Dodge Charger
391 Great Deals out of 28,078 listings starting at $1,988

Used Cars For Sale

1997 Toyota Supra For Sale
2 listings starting at $63,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.