i am having a problem with a newly installed fuel pump. now when i turn on the ignition i am not getting power to the fuel pump

Asked by Aug 12, 2012 at 11:44 AM about the 1986 Toyota Supra 2 dr Hatchback

Question type: Maintenance & Repair

2 Answers

55

well I would go back to your mechanic and have them make sure they hooked your wires back to the fuel pump correctly you probally have some bad connection somewhere

155

The fuel pump power wire connector is located just in front of the shifter. If you remove the center console, you should be able to check the connector and find out if it's getting power and if it's connected properly.

Your Answer

Toyota Supra Experts

  • #1
    Stephen Sidman
    Reputation
    80
  • #1
    James Hayman
    Reputation
    80
  • #3
    littlehorn
    Reputation
    50
View All

Related Models For Sale

Used Ford Mustang
354 Great Deals out of 42,608 listings starting at $1,488
Used Nissan Skyline
12 listings
Used Mazda RX-7
69 listings
Used Chevrolet Camaro
415 Great Deals out of 31,698 listings starting at $3,495
Used BMW M3
34 Great Deals out of 1,883 listings starting at $5,495
Used Chevrolet Corvette
118 Great Deals out of 16,190 listings starting at $3,995
Used Dodge Charger
333 Great Deals out of 36,008 listings starting at $1,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.