had a new vanos unit fitted car starts but only runs for a few seconds

Asked by Oct 15, 2014 at 12:21 PM about the 2002 BMW X5 3.0i

Question type: Maintenance & Repair

02 x5 can bot get it to run fitted new vanos and gears reset timing still will not run

1 Answer

247,395

Scan for codes, what did you get?

Your Answer

Add photo

Related Questions

Search BMW X5 Questions

BMW X5 Experts

#1 Tom Demyan
Tom Demyan
Reputation 1,650
#2 Robert Charlson
Robert Charlson
Reputation 700
#3 Asiamah6910
Asiamah6910
Reputation 550
View All

Related Models For Sale

Used BMW 5 Series
477 Great Deals out of 16,617 listings starting at $2,000
Used BMW 3 Series
995 Great Deals out of 31,636 listings starting at $1,000
Used Mercedes-Benz M-Class
237 Great Deals out of 5,693 listings starting at $1,500
Used Jeep Grand Cherokee
1,040 Great Deals out of 72,524 listings starting at $1,200
Used Porsche Cayenne
127 Great Deals out of 5,060 listings starting at $3,999
Used Acura MDX
298 Great Deals out of 17,756 listings starting at $1,900
Used BMW 7 Series
171 Great Deals out of 6,174 listings starting at $2,740

Used Cars For Sale

2017 BMW X5 For Sale
30 Great Deals out of 6,545 listings starting at $47,401
2016 BMW X5 For Sale
15 Great Deals out of 438 listings starting at $32,800
2015 BMW X5 For Sale
47 Great Deals out of 756 listings starting at $25,995
2014 BMW X5 For Sale
143 Great Deals out of 1,900 listings starting at $25,995
2013 BMW X5 For Sale
47 Great Deals out of 829 listings starting at $15,923

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.