I have a 1989 chevy s-10 blazer 4.3L. ,,it has been sitting in a garage for 8 years . I changed out the old gas ,, but when I start it ,,it has a real rough idle ,,when I put it into gear it's even worse

Asked by Sep 18, 2013 at 05:59 AM about the 1989 Chevrolet S-10 Blazer STD

Question type: Maintenance & Repair

2 Answers

246,205

Did you change the oil and filter, check for vacuum leaks, pull the plugs, inspect the wires, dist. cap and rotor?

1 of 1 people found this helpful.

I'd check the injectors.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,510
#2 Cody Doud
Cody Doud
Reputation 620
#3 emtfirefighter77
emtfirefighter77
Reputation 330
View All

Related Models For Sale

Used Chevrolet Blazer
1,184 listings starting at $1,495
Used Chevrolet S-10
9 Great Deals out of 1,309 listings starting at $1,999
Used Ford F-150
2,169 Great Deals out of 195,112 listings starting at $290
Used Chevrolet Camaro
347 Great Deals out of 31,370 listings starting at $2,500
Used Ford Mustang
714 Great Deals out of 44,996 listings starting at $1,500
Used Jeep Cherokee
410 Great Deals out of 40,808 listings starting at $1,500
Used Chevrolet Corvette
209 Great Deals out of 22,044 listings starting at $2,500
Used Toyota 4Runner
227 Great Deals out of 19,106 listings starting at $1,500
Used Chevrolet Monte Carlo
12 Great Deals out of 1,425 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.