I have a 1989 chevy s-10 blazer 4.3L. ,,it has been sitting in a garage for 8 years . I changed out the old gas ,, but when I start it ,,it has a real rough idle ,,when I put it into gear it's even worse

Asked by Sep 18, 2013 at 05:59 AM about the 1989 Chevrolet S-10 Blazer STD

Question type: Maintenance & Repair

2 Answers

236,785

Did you change the oil and filter, check for vacuum leaks, pull the plugs, inspect the wires, dist. cap and rotor?

1 out of 1 people think this is helpful.

I'd check the injectors.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,440
#2 Cody Doud
Cody Doud
Reputation 610
#3 emtfirefighter77
emtfirefighter77
Reputation 330
View All

Related Models For Sale

Used Chevrolet S-10
8 Great Deals out of 1,349 listings starting at $1,395
Used Chevrolet Blazer
3 Great Deals out of 1,162 listings starting at $500
Used Chevrolet Camaro
205 Great Deals out of 30,805 listings starting at $1,217
Used GMC Jimmy
258 listings starting at $2,495
Used Ford F-150
2,218 Great Deals out of 205,257 listings starting at $1,499
Used Chevrolet C/K 1500
902 listings starting at $2,500
Used Chevrolet Monte Carlo
19 Great Deals out of 1,402 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.