Runs fine cold, but after about 30 minutes of driving the engine starts sputtering and doesn't want to accelerate. What could be the cause?

Asked by Mar 13, 2015 at 11:49 AM about the 1995 Mercedes-Benz E-Class E 320

Question type: Maintenance & Repair

1 Answer

May be running rich, that is often what happens when runs well cold then when warmed up begins to do what you describe. MAF, MAP, several things. I see 1995 but it MAYBE is OBDII. If it is, a scan will help. Live long and prosper.

1 of 1 people found this helpful.

Your Answer

Mercedes-Benz E-Class Experts

  • #1
    Tom Demyan
    Reputation
    2,170
  • #2
    dandyoun
    Reputation
    1,930
  • #3
    bobkat
    Reputation
    1,410
View All

Related Models For Sale

Used Mercedes-Benz C-Class
591 Great Deals out of 23,334 listings starting at $1,995
Used Mercedes-Benz S-Class
134 Great Deals out of 5,947 listings starting at $2,000
Used BMW 5 Series
494 Great Deals out of 16,616 listings starting at $2,000
Used BMW 3 Series
1,047 Great Deals out of 31,561 listings starting at $1,000
Used BMW 7 Series
161 Great Deals out of 6,030 listings starting at $2,500
Used Mercedes-Benz SL-Class
46 Great Deals out of 2,722 listings starting at $4,500
Used Audi A6
144 Great Deals out of 6,326 listings starting at $1,950

Used Cars For Sale

2018 Mercedes-Benz E-Class For Sale
1,505 listings starting at $55,295
2017 Mercedes-Benz E-Class For Sale
67 Great Deals out of 6,513 listings starting at $39,917
2016 Mercedes-Benz E-Class For Sale
24 Great Deals out of 1,043 listings starting at $27,995
2015 Mercedes-Benz E-Class For Sale
58 Great Deals out of 1,457 listings starting at $18,950
2014 Mercedes-Benz E-Class For Sale
77 Great Deals out of 2,578 listings starting at $18,980

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.