With a charged battery and the clutch pushed in ,nothing happens when i try to start. This happened after changing the valve covers. Could i have accidentally unplugged something?

Asked by Nov 26, 2014 at 06:00 PM about the 1970 Chevrolet Chevelle

Question type: Maintenance & Repair

Was running great, I  replaced the valve covers and noticed a couple bare wires near the distributor unplugged but they look like they have been for a while. when I get in an turn the key nothing happens, no dome light ,head lights, no dash lights. Totally dead now, checked fuse panel all ok . could the clutch have anything to do with it ?

1 Answer

75

I know it sounds simple,but MAKE SURE you have a good battery connection.had simaler thing here and it was bad reproduction battery clamps, changed them over no more problems. Good luck

Your Answer

Add photo

Related Questions

Search Chevrolet Chevelle Questions

Chevrolet Chevelle Experts

#1 Squatt
Squatt
Reputation 560
#2 LouB
LouB
Reputation 270
#3 18TandSVT
18TandSVT
Reputation 230
View All

Related Models For Sale

Used Chevrolet Camaro
309 Great Deals out of 38,867 listings starting at $1,250
Used Chevrolet Corvette
202 Great Deals out of 20,888 listings starting at $4,993
Used Ford Mustang
396 Great Deals out of 44,403 listings starting at $1,000
Used Chevrolet Impala
799 Great Deals out of 34,708 listings starting at $799
Used Dodge Challenger
236 Great Deals out of 24,977 listings starting at $7,988
Used Dodge Charger
395 Great Deals out of 30,065 listings starting at $2,343
Used Chevrolet Nova
170 listings
Used Chevrolet Monte Carlo
12 Great Deals out of 1,692 listings starting at $2,300
Used Pontiac GTO
11 Great Deals out of 488 listings starting at $6,500
Used Chevrolet Malibu
1,077 Great Deals out of 85,119 listings starting at $1,995
Used Chevrolet El Camino
207 listings starting at $11,000
Used Pontiac Firebird
13 Great Deals out of 797 listings starting at $2,991