Hey I have a 83 Chevy blazer that I'm about to start working on and I asked the guy why I hasnt ran in 8 years and he said the water want flowing right. Does anyone know why that would happen


Asked by May 14, 2015 at 12:56 PM about the 1983 Chevrolet Blazer 4WD

Question type: Maintenance & Repair

3 Answers


Impellers bad on the water pump, radiator flow is blocked, bad thermostat.


that is what he said,the water pump has a gear inside called a impeller they are press fitted on to a bearing shaft,the impeller can be loose causing por flow of coolant


Yep they can come loose but I have seen more of them just rust away.

Your Answer

Add photo

Related Questions


Looking for a Used Blazer in your area?

CarGurus has 1,648 nationwide Blazer listings starting at $1,999.


Search Chevrolet Blazer Questions

Chevrolet Blazer Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 1,690
#2 yetilikesbeer
Reputation 1,010
#3 dandyoun
Reputation 640
View All

Related Models For Sale

Used Chevrolet S-10"
13 Great Deals out of 1,811 listings starting at $1,749
Used GMC Jimmy"
366 listings starting at $1,900
Used Ford Bronco"
214 listings
Used Ford F-150"
3,272 Great Deals out of 216,641 listings starting at $1,500
Used Chevrolet Camaro"
798 Great Deals out of 38,849 listings starting at $2,650
Used Chevrolet Impala"
928 Great Deals out of 35,693 listings starting at $1,500
Used Chevrolet Suburban"
662 Great Deals out of 24,093 listings starting at $1,500

Used Cars For Sale

2005 Chevrolet Blazer For Sale
12 listings starting at $3,450
2003 Chevrolet Blazer For Sale
156 listings starting at $2,450
2001 Chevrolet Blazer For Sale
231 listings starting at $3,850