s10 v6 cranking, firing and has spark but will not start? what could it be

Asked by Jul 14, 2013 at 11:48 AM about the 2002 Chevrolet S-10 LS LB RWD

Question type: Maintenance & Repair

s10 v6 cranking, firing and has spark, also hear fuel pump at gas tank but will not start what could it be?

38 Answers

215

IF it cranks Like a Bear, and your getting spark! "Pull plug wire off,put screw driver thru plug ring,have someone cranck it over while touching the block,or a bracket, and should see spark" If you see spark, My un- Educated guess would be Timing Belt or chain, Good Luck,

12 people found this helpful.
80,325

Run a compression test. If all cylinders are low your timing chain has jumped or is broken. HTH. -Jim

5 people found this helpful.
22,305

fuel pressure test. 4.3 vortec is know for failed pressure reg and fuel pumps. Should be between 55 and 65

9 people found this helpful.
170

Could be a bad distributor cap from moisture (if it is the flat type). My Blazer had fuel and spark but would not start. It was cranking very weird. What I mean was it would crank for three seconds then all the lights would go dead like the motor was locking up then it would crank for another three seconds. I poured gas into the intake, no help. I then pulled #1 spark plug and cranked it and it was getting spark? Weird, so I thought I had a major timing issue. My buddy recommend changing the cap as the 4.3, 5.7 Vortecs with the flat type caps are notorious for building up moisture in the cap. Changed the cap and wholla... fired right up. Also got a bonus by the check engine light that I has for years was extunguished... crazy but very happy!

17 people found this helpful.
45

I agree. sounds like a timing issue,

4 people found this helpful.
300

1996 Chevy s10 will not start

30 people found this helpful.
730

4.3 have spark fuel pressure but not starting

73 people found this helpful.
560

Hello guys. I have problems with my 1994 Chevy s10 blazer. when I put the key in and turn it will NOT start right up. it will crank but not start. what can the issue be

52 people found this helpful.
50

when it doesn't start, you need to test fuel injectors for 12 volts and a pulse

5 people found this helpful.
95

What about the ECM module. They fail often in Chevy's and it is that module that sends the signal to the fuel injectors to tell them to fire. This may be the case particularly if the spark plugs are bone dry after several unsuccessful attempts to start the engine.

9 people found this helpful.
250

I have a 1996 cheb s10 4.3L v6 vortex, I change spark, wires,distributor, rotor button, fuel filter, crank sensor, cam sensor, when I tried to drive it. It would sputter and it will not accelerate, just more sputtering.

25 people found this helpful.
30

I'm by no means an expert but Sounds like fuel pump to me.. The same thing happen to me in my van and I changed the fuel pump and it fixed it..

3 people found this helpful.
10

Yeah I had a Blazer that did that, changed O2 sensor, fuel pump, sensor, and filter.It would drive ok for awhile then just spudder, Made it all the way from KY to MIch. one time and it broke down on the way back. Well ended up being a cracked injector and cost me $600,00. I hope it's something more simple for you.

1 people found this helpful.
30

On my S-10 I replaced ignition module, coil,cam sensor, crank sensor without success in starting engine, I then replaced cap & rotor button that looked good, my engine started like new, verify that distributor cap is tightly mounted as some new caps come with screws that are to long & though they are tight, cap is not tightly mounted.

3 people found this helpful.
300

I have a 2000 S10 that will not start change the fuel pump it will not start but fires the gas is not coming out of the line it don't go through the filter and we bought a new one and still have the same problem what can be wrong

30 people found this helpful.
180

Just did head gaskets got it all back together. timings and fuel are good.still not starting..anyone with any ideas thanks

18 people found this helpful.
400

I have a 01 S10 pickup 4.3 it's wanting to start but it isn't I check the fuel pump that's working I check the fuel pressure that's working fuel filter changed I'm wondering if it's the timing or something I don't know but I can't figure it out but I have any answers

31 people found this helpful.
400

I have a 01 S10 pickup fuel pump has been checked fuel filters been changed it wants to start but it isn't comments answers for me thank you

9 people found this helpful.
60

Sounds like the ignition control module under the distributor. It commands the fuel injectors to fire.

6 people found this helpful.
30

I have a 1998 2.2l doing the same thing ill be working on it today if i get it going i will let ypu know exactly what i did

3 people found this helpful.
280

My 1995 S10, 4.3 was running rough so I replaced the cap and rotor, which were well beyond worn. Also replaced plugs and wires, which showed normal wear. Now it will crank like a champ but doesn't start. Getting spark all the way to the plugs, but it doesn't even try. Getting plenty of gas, and it was running just before I started working on it. I put the old cap and rotor back on with no luck.

26 people found this helpful.
50

I have a Chevy 98 S10 2.2 Vortec already change the spark plugs the starter the alternator the battery the spark plugs already but it won't start no crank to start it them i just turr the keys and the starter woeks good is all new but the motor doesn't want like crank what could be the problem

5 people found this helpful.
280

I ended up replacing the ICM to no avail. Then i replaced the ERG valve, which was dirty to the point of not moving, and cleaning it didn't help. New ERG, problem fixed.

2 people found this helpful.
50

I have a 2002 s10 4.3 vortec ..it has problems cranking in the morning time but after ot runs it cranks fine..

4 people found this helpful.
50

What could be wrong

1 people found this helpful.
55

I have a 2001 blazer when you turn on key fuel pressure goes up to 60psi and when you start it goes to 63 psi when you turn it off fuel pressure dropped fast to 0psi

5 people found this helpful.
40

I don't no but I have a 99 blazer put.a new motor in it it ran in the s10 they took it out of I put it in the blazer an even put a new starter on it I turn the key on all lights come on but when you go to start it nothing what could it be wrong anybody

4 people found this helpful.
30

My 88 has spark, fuel and air! I've changed everything but the distributor? Could that be the issue, incorrect spark and fuel distribution?

3 people found this helpful.
50

Ive had this same no start multiple times.the fuse box has gotten crispy where all the terminals for fuses are. I had to reroute multiple wires to independent fuse holder because of bad factory fuse box. Start with multimeter with key in on position and check that the fuse box wires actually get power from the fuses. Result of cheaply made fuse box all the connectors falling apart. The no start began with a cracked distributor. Another cheaply made factory item. Horrid flaws in casting make it break in half under load from cam shaft. Replaced it with a lifetime one from autozone an fixxed for awile. Then had a light intake gasket leak moisture in oil. So replaced gasket an hasnt ran right since. Been over everything a hundred times. Well today it cranks random plugs fire but no start. Puking gas thru exhaust but throttle plate has clean mist spray from injectors. Im thinking distributor cracked again or jumped timing chain or ignition component bad. At this point i think a stick of dynomite is the only logical solution

3 people found this helpful.
10

check for pluged cat converter remove up streem o2 sensor and see if starts

1 people found this helpful.
10

OK, here is my Solution to rebuilding the 4.3 vortec only to have no start and misfire conditions. Step 1: follow the instructions with an open mind.... They are mostly right and a great guide. Step 2: forget any other motor than the vortec motor while working on it. Step 3: LOOK AT PICTURES OF NEW PARTS. STEP 4: LOOK AT YOUR PARTS NEXT TO THE PICTURES My 0 mile rebuild sounded like a 21 gun salute the first time it started. I thought the ECU may have needed to reset for the new sensors. NOPE.... Redid the timing chain over and over making sure everything lined up perfectly by the marks.... Fail.... after 2 months of forum reading, readjusting, failure, frustration, way too may new parts to replace new parts, I found my harmonic balancer had shifted. the marks were about 90 degrees off. So I brought the #1 piston to top dead center (again). this time I made sure both valves were closed, marked the balancer on the timing mark at the timing cover. installed the distributor dead on. Rotated the motor 720 degrees to verify everything continued to line up. I put the truck back together and...... NOTHING.... I only found this in one forum, nowhere else, not in a manual, not on GMs technician data, not on alldataDIY, just a forum. after verifying everything lines up, ROTATE THE CRANKSHAFT 360 DEGREES AND REINSTALL THE DISTRIBUTOR. Finally, the truck runs without backfiring, Idling extremely high (2400 RPM idle) or blowing apart Mass Airflow Sensors.

1 people found this helpful.
50

Well engine is done finally got it to start only to discover passenger rear cylinder had detonated so hard it blew a hole thru side of the block in compression area of cylinder wall. I suspect the new distributor failed again. Have a 4.3liter L99 vented optispark v8 aka baby LT1. I wonder if it would bolt to transmission in early alum intake 4.3 liter v6? Anyone ever tried this? I know engine mounts diff and need ecm with Lt but does transmission mount up the same?

1 people found this helpful.
50

The one I have doesn't use a cat or 02 an egr removed. Basically set up with min stuff to go wrong but there's one item can't get decent part so I'm done with 4.3 v6. Brand new life time warranty auto zone distributor flops around in its housing bad bearings. Detonated an blew hole in block. To bad really liked the torque of first gen 4.3 v6 but that's a flaw I'm done dealing with.

1 people found this helpful.
22,305

Chuck, sounds like you shot yourself in the foot a little here. You deleted egr on an engine that is known to have ping (detonation) problems. Egr directly combats engine ping. Sorry you had issues but I'd hardly call the distributor a weak link in a 4.3

1 people found this helpful.
20

I have a 2000 Chevy blazer have put a new timing chain new crank sensor new distributor new distributor cap new button new computer and a new battery and it still won't start any helpful suggestions on what it could be

2 people found this helpful.
10

So if I have fuel at the rail, spark compression test done and all great, why after putting new pump in will it not start.before I changed the pump it would need primed but afterwards it would start fine. Then changed it the truck is same but worse. Now my pump wires where cut after putting new pump in and shorted out the relay on (ecm) now does that mean my relay to my fuel pump relay is fired should I change that?, ok now when primed now with new pump the truck runs when I give it gas it dies out, but will die once prime is gone. What's your opionon on this? Please anyone!

1 people found this helpful.
30

I have a 90 Chevy getting fire and gas to throttle body just won't spray at all what do I do

3 people found this helpful.
22,305

The pickup in the distributor is used to fire the injectors

2 people found this helpful.

Your Answer:

S-10

Looking for a Used S-10 in your area?

CarGurus has 867 nationwide S-10 listings starting at $2,988.

ZIP:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,830
  • #2
    John Saffrahn
    Reputation
    1,120
  • #3
    Trebor66
    Reputation
    1,110
View All

Related Models For Sale

Used Ford Ranger
104 Great Deals out of 4,208 listings starting at $1,700
Used Chevrolet Silverado 1500
1,787 Great Deals out of 155,768 listings starting at $1,495
Used Toyota Tacoma
429 Great Deals out of 49,110 listings starting at $2,400
Used GMC Sonoma
3 Great Deals out of 290 listings starting at $2,150
Used Ford F-150
2,319 Great Deals out of 198,937 listings starting at $1,300
Used Chevrolet Blazer
5 Great Deals out of 729 listings starting at $900
Used Dodge Dakota
80 Great Deals out of 3,028 listings starting at $1,000
Used Nissan Frontier
319 Great Deals out of 22,064 listings starting at $1,295
Used GMC Sierra 1500
804 Great Deals out of 60,078 listings starting at $1,495
Used Dodge Ram 1500
346 Great Deals out of 9,243 listings starting at $1,800
Used Chevrolet Camaro
242 Great Deals out of 26,934 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.