Car question

70

Asked by Oct 14, 2016 at 06:21 PM about the 1996 Chevrolet S-10 2 Dr LS Standard Cab SB

Question type: General

I have a complete tune up,ever the coil,.when I
try to accelerate, it just sputter

1 Answer

106,355

A couple of things to look at, try changing the TPS you may want to look for a vacuum leak, check all your hoses and I would check to see what your fuel presuure is. There maybe junk clogging the screen in the pump.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,360
#2 John Saffrahn
John Saffrahn
Reputation 1,000
#3 Trebor66
Trebor66
Reputation 990
View All

Related Models For Sale

Used Ford Ranger
169 Great Deals out of 5,600 listings starting at $900
Used GMC Sonoma
5 Great Deals out of 429 listings starting at $1,488
Used Toyota Tacoma
529 Great Deals out of 42,957 listings starting at $1,995
Used Ford F-150
2,126 Great Deals out of 193,347 listings starting at $290
Used Dodge Dakota
132 Great Deals out of 3,787 listings starting at $1,500
Used Chevrolet Blazer
1,168 listings starting at $1,495
Used GMC Sierra 1500
769 Great Deals out of 68,508 listings starting at $1,800
Used Dodge Ram 1500
404 Great Deals out of 10,928 listings starting at $1,000
Used Chevrolet C/K 1500
3 Great Deals out of 864 listings starting at $1,950
Used Chevrolet Camaro
351 Great Deals out of 31,326 listings starting at $2,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.