Vacuum problem?

Asked by Jan 18, 2016 at 11:14 PM about the 2003 Chevrolet Monte Carlo LS

Question type: Maintenance & Repair

My 2003 Monte has split driver/passenger
temp control.  The driver side is stuck on
cold.  The lever slides up and down as
smoothly as the passenger side, without
any resistance.  But the temp bless cold
even when it is set on the hot setting.  Is
there a vacuum line that maybe came loose,
or could it be something else?

1 Answer

71,375

They are ACHV blend door actuators, Run electrically, Just replace them.

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Search Chevrolet Monte Carlo Questions

Chevrolet Monte Carlo Experts

#1 Tom Demyan
Tom Demyan
Reputation 520
#2 Js08016
Js08016
Reputation 460
#3 John Saffrahn
John Saffrahn
Reputation 410
View All

Related Models For Sale

Used Chevrolet Impala
589 Great Deals out of 34,066 listings starting at $899
Used Chevrolet Camaro
244 Great Deals out of 31,183 listings starting at $369
Used Ford Mustang
543 Great Deals out of 45,840 listings starting at $1,999
Used Chevrolet Corvette
149 Great Deals out of 20,682 listings starting at $3,995
Used Pontiac Grand Prix
31 Great Deals out of 2,863 listings starting at $1,600
Used Chevrolet Malibu
1,059 Great Deals out of 77,896 listings starting at $1,500
Used Chevrolet Silverado 1500
1,769 Great Deals out of 181,161 listings starting at $250
Used Chevrolet Tahoe
556 Great Deals out of 31,361 listings starting at $1,500
Used Buick Regal
129 Great Deals out of 11,074 listings starting at $2,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.