my push button 4x4 switch is not lighting up and not working

Asked by Nov 20, 2013 at 04:20 PM about the 1991 Chevrolet S-10

Question type: General

1 Answer

96,825

Check the lamp, it has to be operating for the system to work.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,360
#2 John Saffrahn
John Saffrahn
Reputation 1,000
#3 Trebor66
Trebor66
Reputation 990
View All

Related Models For Sale

Used Ford Ranger
168 Great Deals out of 5,599 listings starting at $1,200
Used GMC Sonoma
4 Great Deals out of 436 listings starting at $1,488
Used Ford F-150
2,185 Great Deals out of 194,802 listings starting at $290
Used Dodge Dakota
124 Great Deals out of 3,817 listings starting at $1,500
Used GMC Sierra 1500
800 Great Deals out of 68,894 listings starting at $1,800
Used Chevrolet Blazer
1,185 listings starting at $1,495
Used Chevrolet C/K 1500
871 listings starting at $1,950
Used Chevrolet Camaro
351 Great Deals out of 31,424 listings starting at $2,500

Used Cars For Sale

2004 Chevrolet S-10 For Sale
52 listings starting at $2,695
2003 Chevrolet S-10 For Sale
3 Great Deals out of 306 listings starting at $1,999
2002 Chevrolet S-10 For Sale
4 Great Deals out of 205 listings starting at $2,880

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.