No power when cold !

Asked by May 11, 2010 at 09:39 PM about the 1994 Ford Ranger

Question type: Maintenance & Repair

I have a 94 ranger that has no power when I first start it. If I drive it with out letting it warm up it sometimes seems to misfire/backfire and will hesitate. It has no power. If I let it warm up a few minutes it will run ok.

Has anyone else had this problem? Anyone have any ideas on what could be causing this?

2 Answers

sounds like you need to replace your fuel filter.

1 of 1 people found this helpful.

O2 sensor?

1 of 1 people found this helpful.

Your Answer

Ford Ranger Experts

  • #1
  • #2
  • #3
    Bob Beaman
View All

Related Models For Sale

Used Toyota Tacoma
431 Great Deals out of 40,775 listings starting at $2,600
Used Ford F-150
2,525 Great Deals out of 219,810 listings starting at $1,222
Used Dodge Dakota
63 Great Deals out of 3,139 listings starting at $1,600
Used Chevrolet S-10
9 Great Deals out of 1,005 listings starting at $999
Used Jeep Wrangler
305 Great Deals out of 20,092 listings starting at $2,900
Used Dodge Ram 1500
325 Great Deals out of 9,561 listings starting at $800
Used GMC Sierra 1500
885 Great Deals out of 59,068 listings starting at $1,980
Used Ford Mustang
288 Great Deals out of 38,306 listings starting at $1,995

Used Cars For Sale

2011 Ford Ranger For Sale
25 Great Deals out of 691 listings starting at $3,988
2010 Ford Ranger For Sale
9 Great Deals out of 369 listings starting at $2,900
2009 Ford Ranger For Sale
10 Great Deals out of 255 listings starting at $3,500
2008 Ford Ranger For Sale
13 Great Deals out of 368 listings starting at $3,000
2007 Ford Ranger For Sale
11 Great Deals out of 266 listings starting at $2,750

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.