98 2.0 eclipse error codes p0171/p0301

155

Asked by Aug 30, 2013 at 04:23 PM about the 1998 Mitsubishi Eclipse GS

Question type: Maintenance & Repair

My daughter has a 98 mitsubishi eclipse 2.0.129,000miles she has replaced the plugs and wires, It has error codes p0171 and p0301 lean fuel, i have checked for vacuum and gasket leaks with brake cleaner no indication of leak any where have checked fuel injectors for continuity all around 14 ohms. I have erased codes but eventually come back, at first start will run and rev perfect for 3-5 minutes then run a little rough, if i turn it off and restart will run perfect, this  happens on all restarts and after 3-5 min it returns to run rough. has new air cleaner and have run lucas injector cleaner instead of taking rail and injectors out and cleaned manifold sensor. any help would be appreciated thanks for reading hoyze1@yahoo.com

70 Answers

109,985

http://www.obd-codes.com/p0171

6 of 6 people found this helpful.
109,985

http://www.obd-codes.com/p0301

3 of 3 people found this helpful.
109,985

Maybe those will help you narrow down the potential causes of the codes.

3 of 3 people found this helpful.
6,015

you should verify that your getting the proper amount of fuel pressure,, a weak fuel pump or faulty fuel pressure regulator or even clogged injectors can cause this issue, also a faulty O2 sensor could be messing you up from a guy that had the same 0171 error "Finally this thing is fixed! Replaced the Bank 1 O2 Sensor and all is good again. Went ahead and replaced the Bank 2 O2 because it had never been done. Shes runnnin great again"

2 of 2 people found this helpful.
6,015

and heres another one as well --- "I know this is old but I've had the same problem and just recently fixed the p0171 code that keeps popping up. First thing I did was clean the MAF sensor and that didn't work. Then i took out the whole intake system to gain clearance to check out all the hoses and they look fine. Last thing I did was took out the b1s1 o2 sensor, which is right behind the intake manifold plenum, and cleaned it out by blowing on it and whipping it down with a dry towel. The code doesn't come on anymore. I hope this helps some people out there. "

3 of 3 people found this helpful.
6,015

the more I read about ppl with these 0171 error codes the more I find its bad O2 sensor read some of these links and let us know how your getting along please

2 of 2 people found this helpful.
155

thank you for the help will check again to see if i missed anything, daughter says she replaced both o2 senors but not fuel filter, just dont understand when it runs rough you just restart it and its ok ?????

6,015

that's cause you sorta reset the computer ,, by that I mean its gotta relearn the conditions and then it fouls out when it starts getting false readings if that makes sense to ya

2 of 2 people found this helpful.
6,015

a clogged filter can do this,, but I would think that you would get misfire on more than one cylinder ... I know ya said ya checked the injectors and they checked out alright but what about the flow, they could also be clogged and what about that furl pressure regulator ?? ,, ill grind on this some more and see what I can come up with

1 of 1 people found this helpful.
155

ya i figured as much, but it's nice to get someones opinion, so your telling be on every restart it relearns i know when i disconnected battery it reset. she actually had bought a new regulator but never installed it, i will remove rail and injectors to check for flow just thought id try the cleaner, never have got any type of crap to work. i appreciated your input its helpful to talk to someone who knows what im talking about thanks

6,015

yeh get that low checked out and also might as well get that fuel pressure regulator installed since you already have it bought n paid for

155

both o2 senors have been replaced, kinda figured about comp. relearning, going to change regulator and remove the injectors to check for clog going to check for egr if it has one, know american cars a lot better, will need to get gage to check pressure but think it would affect all cylinders. thanks

155

she had most of the vacuum lines replaced, but i do hear a hiss by the fire wall or front of motor but not sure if its the motor, not use to what it sounds like, im going to bring it home so i can remove manifold and injectors and give me more room to look back there. she has'nt replaced egr there is two lines one had air flow the other didnt, dont know if its normal. One thing i noticed today is slow acceleration is ok and also had to put gas in with a can and fuel came pouring out of the neck metal against metal former owner zip striped it (dumb ass)so there is no pressure in tank is that a possible cause THANKS AGAIN !!!

6,015

well get that hissing sound checked out and fixed as far as that hole in the gas tank filler neck causing you problems im not sure if this is the cause or whatever but you should get that fixed asap, exploding cars don't get check engine lights ever

1 of 1 people found this helpful.
109,985

How many miles? Have you checked your timing belt? If over 100000 might be something to look into.

2 of 2 people found this helpful.
155

129,000 ya i thought of that, didnt really want to think about it, daughter says its been doing it for about a year. never done one ill have to research how to check it. have a mechanic i trust but low on funds right now plus she wants to learn, i

1 of 1 people found this helpful.
155

l.o.l. daniel, ya my eyes got pretty big when i saw the fuel pouring not dripping out some people shouldnt have kids or cars thanks to you and dandy for input appreciate the help and sounding board

1 of 1 people found this helpful.
109,985

It's not really that hard to replace timing belt. Just take your time and make sure you get all the timing marks lined up. Best way is to line it all up before you remove the old belt if you can. If your are going to change it I would also change the idler/tensioner pullies and also water pump at the same time. If old belt does not line up on all timing markes do a compression check to check for any bent valves. Doubt seriously that you have any bent tho since it is running but I would check just in case.

2 of 2 people found this helpful.
155

the belt passes visual inspection and is tight, the tensioner pullie bearings are going out its screeching bad, i spray it and its quiet for a while

6,015

get that tensioner changed fore it seizes up and wrecks your belt and jumps time,, also just cause its tight don't mean it didn't jump time so check that its still all in time

2 of 2 people found this helpful.
109,985

I agree with Daniel. Don't drive it like that. Major issues if it jumps time. And you are talking about the timing belt tensioner? You have to remove all other belts and some plastic shields just to be able to see the timing belt tensioner let alone be able to spray it with something.

1 of 1 people found this helpful.
155

havent moved it, the tensioner(assuming thats what it is) is on the outside, and has a wide belt like a serpentine but there is two belts on this, gonna wait till dark so i can see better

109,985

Oh ok. So if you haven't removed any belts or plastic shields then I don't think it's the timing belt you are looking at. You are probably looking at the acc belts (ac, power steering, alt, ect)

1 of 1 people found this helpful.
6,015

sounds like your talking about the harmonic balancer/crank pulley

1 of 1 people found this helpful.
155

yes, sorry just assumed, how can you tell if belt is going bad, from what ive read its kinda hard to tell unless the belt shows ware and tear which i dont see it looks fairly new. gonna wait for dark and check for leaks under manifold. if i unhook no. 1 will that help me determine anything besides dead injector(dont think is the case, maybe dirty) thank you

109,985

Although the 2.0 and the 2.4 do have two timing belts. The small one is for the balancer shaft and the other is the normal timing belt. But both are hid behind a lot of other stuff.

2 of 2 people found this helpful.
109,985

Orielys has a real reasonably priced kit for your model.

1 of 1 people found this helpful.
155

ya the cover has a hole in it can see the cam pullies and belt

1 of 1 people found this helpful.
109,985

Oh ok.

1 of 1 people found this helpful.
155

ya my daughter was getting parts from A.Z. told her about orielys, they were real helpfull to her and explained stuff to her

109,985

They are both good. Just make sure you are getting quality timing belts and pulleys cause you sure don't want them to fail.

1 of 1 people found this helpful.
155

can only see 1, ya not a place to pinch pennys. I wish the people that designed these had to work on them, have a buick regal 3800 pretty easy to work on (which is rare great motor)

155

is it me or everybody, when i work on a friends car or their friend its usually an easy fix, but when its my kids its a pain in the butt

109,985

Yes I know. Just replaced the ones on my wife 2003 eclipse spyder and there is little room to work. The smaller belt is down low in the cover (all the way on the bottom) and behind the larger timing belt.

2 of 2 people found this helpful.
109,985

Lol. Join the club of do it yourselvers. Just built a 91 3000 gt for my fifteen year old. I know what they mean about interference engine. Timing belt was not put on properly and it took out the valves. So after I had the heads redone I made sure I did not make the same mistake twice.

1 of 1 people found this helpful.
155

looked at your site you could start a car lot, i use to have an 85 z28 305 was a fast car for the motor, loved taking out the tops and just driving fun car, but had to sell all my toys when started having kids. would love to have a 68 charger rt(whats another mortgage)

109,985

Yes I like my toys. Getting the camaro back on the road. Put valve guide seals in this weekend. Now it doesn't smoke anymore. Runs like a top. Time to redo the interior and get it painted back all factory colors. Two of my kids are grown and only one left in the house so I have a little more time to tinker with the toys.

1 of 1 people found this helpful.
155

ya throwing good money does that for me to, hope your boy appreciates it, i know they do when its there money, ive got 3 girls and 2 boys bought 3 first cars so far, and 2 more to get soon, then its on their dime.

155

im getting there, have1 left to graduate, then i can get a two wheel toy again, im just wondering if ive lost the need for speed (dont think i did) but since i cant get the rt yet it will do.

109,985

Oh he does. He is afraid to drive it because he thinks its to nice a car for his first one. But he a straight A student and I feel he deserves to ride in what I consider a classic car. But the next ones on him. Lol

1 of 1 people found this helpful.
109,985

One time sitting back in the seat of a hot rod and you will be back up to your elbows in your own toy.

1 of 1 people found this helpful.
Best Answer
109,985

My camaro been in my shed for about fifteen years. But now its time for me to build my toy.

1 of 1 people found this helpful.
155

sound like my youngest boy, know he will take care of it, like i tell my kids be and do the best you can and ill do what ever i can do for you. love em to death all i have to do is read the paper and know ive been blessed with some wonderful kids

155

GOOD LUCK AND ENJOY IT, YOUVE WAITED A LONG TIME FOR THIS AND SOUNDS LIKE YOU DESERVE IT

109,985

That's great. With all that's going on in this world today it says something good about them to stay on the right path. Oh and good parenting has something to do with that too. Lol

2 of 2 people found this helpful.
155

i agree, tell them when im proud of them, give them suggestions, and tell them i love em every chance i get, its paid dividends over and over. thanks again for all your help greatly appreciated, i try to do the same when i can makes ya feel good so many just walk by

6,015

get a room already you two lol

3 of 3 people found this helpful.
109,985

Your welcome. I going back to work tonight and wont be around my iPad again till this coming weekend. I will check on your progress then. Good luck and drive safe

2 of 2 people found this helpful.
109,985

You way to funny Daniel. Although This conversation did wander of the path of fixing his daughters car. Lol. Drive safe

2 of 2 people found this helpful.
155

get your mind out of the gutter daniel.you sicko(lol) taking my mind off this damm car. i cant find a leak anywhere, cant pinpoint the hiss might be normal for it, sprayed the crap out of it nothing. had the air tube off took it for a drive was able to accelerate a little harder than before. the ball or whatever is in PCV was vibrating on and off. she has an exhaust leak, she told me it was repaired but cant remember b4 or after cat. gonna bring it home to what i dont know and put the front end up. TRAVEL SAFE will update

1 of 1 people found this helpful.
155

forgot took the leed off injector 1 ran like crap

6,015

ya know that exhaust leaks will throw errors

1 of 1 people found this helpful.
155

got underneath today its completly in front of the cat. it still sits in there,thats why it wasnt screaming, ive got my fingers crossed

155

im on it, im hoping

155

repaired the exhaust, runs better and no error codes. took out fuel gently and this is what it looked like those tips dont come off easy, and this injector is for no# 1 any input on how to handle this thanks

6,015

get new ones ,, did you check the flow is it good ? thanks for the helpful marks by the way ;/

1 of 1 people found this helpful.
155

welcome, no its been a busy day, and just in case i was looking for the rubber o ring had to look, tried tugging one of the other caps on the injectors no budge , will test them tomorrow for spray.

155

found out they are called pintals, most say for protection from damage and heat ,some say spray ill find out when i test but your opinion would be appreciated, but would imagine there had to be an o ring, fingers crossed thanks

155

i tried using the 1.5 v batt. i seen to test but got no result hooked up to car bat and it clicked but i now realize it has to be under pressure does this sound correct

155

flow is good,egr is good. put some premium in it first mile ran perfect then it started again. drove it about 10 mi. and it just got worse as i went sat at a light and i barely made it back??? have any dynamite

6,015

lol nope sorry on the dynamite but let me take care of some stuff and ill get on the case for ya

1 of 1 people found this helpful.
155

ran perfect longer after i cleaned the idle control ?, on throttle body was filthy, it ran better at low rpm, it ran like at 80% then again stopped at light then took off was like it was getting to much fuel,(injector leaking ?) and just got worse as i went. its also less humid and cooler than it has been, have looked every where found same problem. but have already put new item in for their fix. was doing all this before new parts installed what are the odds replace bad part with new bad part??? signed still looking for dynamite... would a video help????

6,015

have you replaced your iacv Idle air control valve ?

1 of 1 people found this helpful.
155

i posted before what happened to it, no i didnt replace it i just cleaned it, the tip wasnt to bad but the barrel portion was dirty.

6,015

well ive had one that was bad cleaned it, worked great for all of 10 minutes and then I changed it and solved the problem, so as a recap what is you the car doing as we speak and can you get it scanned for up to date codes.. before ya go scan it reset the ECU before ya leave so that theres not any old codes and their all current,, jus nplug the ECU for a cpl minutes will reset it

1 of 1 people found this helpful.
155

haven't run since last post, will replace iac, was going to clean the tps today but couldn't, i don't have my good torx set. will reset ECM. also after exhaust repair didn't get code till i drove it last and that was after 20 min. and i was kind of pushing it, it sounds like it;s ready to break loose and run right but doesn't (if that makes sense to ya) was going to take it today to see if new code but (x-wife drama) will have them check and reset ecu and have them check again THANKS AGAIN

6,015

no problem btw you can bench test a TPS and a IACV

1 of 1 people found this helpful.
155

know of any good places to show me, or just do some research. maybe i can get the x to sit in the car and light the fuse, 2 birds with one stone shes not to bright l.o.l.

1 of 1 people found this helpful.
155

I was reading about crank and cam sensor, was looking on the fire wall side of the motor and there is two sensors, one is plugged in and the other has no wires to the sensor. i found a wire on the harness, there was one wire by it self, its for a flat male pin which the ??? sensor has two, of the two sensors its closer to the rear of the motor any ideas which sensor (knock maybe) also i have read the ecm is in center councel i dont see it, i think mine is under hood heres a pic.

155

I was reading about crank and cam sensor, was looking on the fire wall side of the motor and there is two sensors, one is plugged in and the other has no wires to the sensor. i found a wire on the harness, there was one wire by it self, its for a flat male pin which the ??? sensor has two, of the two sensors its closer to the rear of the motor any ideas which sensor (knock maybe) also i have read the ecm is in center councel i dont see it, i think mine is under hood heres a pic.

Your Answer

Add photo

Related Questions

Eclipse

Looking for a Used Eclipse in your area?

CarGurus has 1,359 nationwide Eclipse listings starting at $1,000.

ZIP:

Search Mitsubishi Eclipse Questions

Mitsubishi Eclipse Experts

#1 dandyoun
dandyoun
Reputation 1,610
#2 Daniel Foster
Daniel Foster
Reputation 730
#3 Tom Demyan
Tom Demyan
Reputation 380
View All

Related Models For Sale

Used Mitsubishi Eclipse Spyder
15 Great Deals out of 519 listings starting at $1,791
Used Ford Mustang
472 Great Deals out of 45,735 listings starting at $1,999
Used Mitsubishi Lancer Evolution
17 Great Deals out of 483 listings starting at $10,950
Used Honda Civic
656 Great Deals out of 88,603 listings starting at $995
Used Chevrolet Camaro
225 Great Deals out of 30,943 listings starting at $1,217
Used Honda Civic Coupe
187 Great Deals out of 16,850 listings starting at $800
Used Toyota Celica
8 Great Deals out of 343 listings starting at $1,000
Used Mitsubishi 3000GT
84 listings starting at $2,999
Used BMW 3 Series
974 Great Deals out of 31,729 listings starting at $1,000

Used Cars For Sale

2012 Mitsubishi Eclipse GS For Sale
27 listings starting at $4,950
2011 Mitsubishi Eclipse GS For Sale
20 listings starting at $6,995
2009 Mitsubishi Eclipse GS For Sale
3 Great Deals out of 136 listings starting at $3,500
2008 Mitsubishi Eclipse GS For Sale
129 listings starting at $3,395

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.