99 mecury cougar had transmission completely rebuilt on Xmas this year has 170,000 miles but now engine runs really ragged when it didn't before the repair?

Asked by Jan 17, 2013 at 05:36 PM about the 1999 Mercury Cougar 2 Dr I4 Hatchback

Question type: Maintenance & Repair

2 Answers

At 170k one probably has nothing to do with the other..that is unless it started to run badly right out of the transmission shop, if any amount of time, if you mean between Dec and now, it ran OK, I think no connection

85

While it could be many things my first guess would be a vacuum leak, An important issue that must be considered is if this started on the way home form the transmission shop you should have taken it back but it too late for that nowl That would be key to you answer alsol .

Your Answer

Mercury Cougar Experts

  • #1
    lisagayle
    Reputation
    2,230
  • #2
    Tom Demyan
    Reputation
    820
  • #3
    Jessica Cornelison
    Reputation
    610
View All

Related Models For Sale

Used Ford Mustang
270 Great Deals out of 37,082 listings starting at $2,150
Used Chevrolet Camaro
224 Great Deals out of 28,922 listings starting at $3,900
Used Mercury Grand Marquis
19 Great Deals out of 1,192 listings starting at $1,200
Used Chevrolet Corvette
101 Great Deals out of 15,517 listings starting at $3,900
Used Chevrolet Impala
397 Great Deals out of 25,595 listings starting at $799
Used Pontiac Firebird
7 Great Deals out of 674 listings starting at $3,695
Used Volkswagen Beetle
112 Great Deals out of 8,183 listings starting at $1,600
Used Chevrolet Malibu
480 Great Deals out of 49,315 listings starting at $2,000
Used Ford F-150
2,344 Great Deals out of 215,477 listings starting at $1,300

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.