99 mecury cougar had transmission completely rebuilt on Xmas this year has 170,000 miles but now engine runs really ragged when it didn't before the repair?

Asked by Jan 17, 2013 at 05:36 PM about the 1999 Mercury Cougar 2 Dr I4 Hatchback

Question type: Maintenance & Repair

2 Answers

At 170k one probably has nothing to do with the other..that is unless it started to run badly right out of the transmission shop, if any amount of time, if you mean between Dec and now, it ran OK, I think no connection

85

While it could be many things my first guess would be a vacuum leak, An important issue that must be considered is if this started on the way home form the transmission shop you should have taken it back but it too late for that nowl That would be key to you answer alsol .

Your Answer

Mercury Cougar Experts

  • #1
    lisagayle
    Reputation
    2,200
  • #2
    Tom Demyan
    Reputation
    800
  • #3
    Jessica Cornelison
    Reputation
    600
View All

Related Models For Sale

Used Ford Mustang
586 Great Deals out of 36,170 listings starting at $1,800
Used Chevrolet Camaro
398 Great Deals out of 30,578 listings starting at $2,495
Used Mercury Grand Marquis
33 Great Deals out of 1,706 listings starting at $1,000
Used Chevrolet Corvette
179 Great Deals out of 19,867 listings starting at $2,490
Used Pontiac Firebird
8 Great Deals out of 887 listings starting at $2,500
Used Mitsubishi Eclipse
22 Great Deals out of 1,183 listings starting at $1,999
Used Ford F-150
2,478 Great Deals out of 193,492 listings starting at $799
Used Chrysler Sebring
29 Great Deals out of 2,717 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.