vacuum problem

Asked by Nov 04, 2015 at 11:53 PM about the 1997 GMC Yukon SLE 4WD

Question type: Maintenance & Repair

no power when running

1 Answer

20

Yes,should be a vacuum problem, I recommend you connect a OBD computer and double check the code because maybe thats the problem, them locate the sector where the problem is and see a mechanic for fix that.

Your Answer

GMC Yukon Experts

  • #1
    clayduster71
    Reputation
    2,540
  • #2
    David Boccabello
    Reputation
    780
  • #3
    Drpsychmom
    Reputation
    650
View All

Related Models For Sale

Used Chevrolet Tahoe
620 Great Deals out of 36,026 listings starting at $1,800
Used Chevrolet Suburban
274 Great Deals out of 20,215 listings starting at $1,195
Used GMC Sierra 1500
781 Great Deals out of 67,901 listings starting at $1,800
Used Ford Expedition
393 Great Deals out of 21,971 listings starting at $1,500
Used Ford F-150
2,221 Great Deals out of 180,841 listings starting at $1,500
Used Jeep Grand Cherokee
917 Great Deals out of 70,536 listings starting at $995
Used Ford Explorer
820 Great Deals out of 62,484 listings starting at $1,495
Used Dodge Durango
281 Great Deals out of 20,105 listings starting at $999
Used Toyota 4Runner
235 Great Deals out of 21,052 listings starting at $1,500

Used Cars For Sale

2017 GMC Yukon SLE 4WD For Sale
818 listings starting at $41,995
2016 GMC Yukon SLE 4WD For Sale
38 listings starting at $35,900
2015 GMC Yukon SLE 4WD For Sale
3 Great Deals out of 159 listings starting at $29,000
2014 GMC Yukon SLE 4WD For Sale
12 listings starting at $25,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.