Why wont my left high beam work

Asked by Oct 11, 2016 at 11:33 AM about the 1999 Ford Crown Victoria Police Interceptor

Question type: Maintenance & Repair

Having a problem with lights, replaced LCM lights
work except left side high beam. Bought new bulbs
still wont work. All other lights work

1 Answer

31,295

Got a voltmeter? Check for power, the bulb holders can go bad. Dielectric grease in the socket can also help.

1 of 1 people found this helpful.

Your Answer

Ford Crown Victoria Experts

  • #1
    Tracy Hooks
    Reputation
    1,940
  • #2
    Tom Demyan
    Reputation
    1,140
  • #3
    tennisshoes
    Reputation
    800
View All

Related Models For Sale

Used Mercury Grand Marquis
25 Great Deals out of 1,575 listings starting at $1,000
Used Ford Taurus
218 Great Deals out of 15,347 listings starting at $1,900
Used Lincoln Town Car
17 Great Deals out of 1,626 listings starting at $2,450
Used Ford Mustang
437 Great Deals out of 42,782 listings starting at $1,488
Used Chevrolet Impala
521 Great Deals out of 33,152 listings starting at $1,495
Used Ford Explorer
1,166 Great Deals out of 64,672 listings starting at $1,200
Used Ford F-150
3,205 Great Deals out of 226,283 listings starting at $1,250
Used Chevrolet Tahoe
887 Great Deals out of 39,488 listings starting at $1,799
Used Honda Accord
884 Great Deals out of 79,051 listings starting at $1,444
Used Toyota Camry
1,082 Great Deals out of 75,994 listings starting at $1,000
Used Chevrolet Camaro
497 Great Deals out of 31,045 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.