I'm not getting power to my radio after battery was replaced. Does anybody have a fix?

Asked by May 03, 2015 at 04:33 PM about the 1997 Geo Prizm 4 Dr LSi Sedan

Question type: Maintenance & Repair

Nothing is lighting up within the radio panel.  it is a 1997 Prizm.

2 Answers

325

It is probably just the fuse. Sometimes when you pull a fuse, the fuse will look like it is okay when it is not.

Sounds like you blew a fuse. Have you checked your fuses?

Your Answer

Geo Prizm Experts

  • #1
    CamaroCollector
    Reputation
    270
  • #2
    Tom Demyan
    Reputation
    170
  • #3
    Nick Keith
    Reputation
    110
View All

Related Models For Sale

Used Toyota Corolla
934 Great Deals out of 65,938 listings starting at $1,995
Used Toyota Camry
1,072 Great Deals out of 72,796 listings starting at $1,000
Used Honda Civic
830 Great Deals out of 78,168 listings starting at $900
Used Geo Metro
10 listings
Used Honda Accord
1,002 Great Deals out of 62,552 listings starting at $999
Used Volkswagen Jetta
571 Great Deals out of 41,868 listings starting at $700
Used Acura Integra
109 listings starting at $1,475
Used Dodge Ram Van
113 listings
Used Volvo S40
29 Great Deals out of 1,024 listings starting at $750
Used Nissan Maxima
331 Great Deals out of 23,618 listings starting at $1,750
Used Acura TL
171 Great Deals out of 5,027 listings starting at $999
Used Acura NSX
285 listings starting at $39,950
Used Ford Focus
752 Great Deals out of 53,087 listings starting at $1,299

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.