my 1999 vw cabrio starts good but soon as it warms up. it starts sputtering and boggin when i try ti drive it.. i already replace the coolant temp sensor. can anyone help please

Asked by Dec 05, 2013 at 08:14 AM about the 1999 Volkswagen Cabrio 2 Dr GL Convertible

Question type: Maintenance & Repair

1 Answer


Hi, I had a similar issue with mine, I thought it was because I drove through some puddles and soaked the electrics but it continued to get worse as the weeks went by. I had to replace the rotor arm and the distribution cap, I also changed the HT leads while I was at it. Solved the problem. Hope this rules helps.

Your Answer

Volkswagen Cabrio Experts

  • #1
    Tom Demyan
  • #2
    Mike Bonnell
  • #3
View All

Related Models For Sale

Used Volkswagen Beetle
123 Great Deals out of 9,137 listings starting at $1,750
Used Volkswagen Jetta
404 Great Deals out of 28,090 listings starting at $1,650
Used Volkswagen GTI
79 Great Deals out of 6,762 listings starting at $1,100
Used Volkswagen Golf
70 Great Deals out of 4,635 listings starting at $900
Used Jeep Wrangler
315 Great Deals out of 19,991 listings starting at $2,900
Used Volkswagen Passat
290 Great Deals out of 26,293 listings starting at $1,000
Used Ford Mustang
287 Great Deals out of 38,472 listings starting at $1,995
Used BMW 3 Series
901 Great Deals out of 32,980 listings starting at $1,300

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.