my 1999 vw cabrio starts good but soon as it warms up. it starts sputtering and boggin when i try ti drive it.. i already replace the coolant temp sensor. can anyone help please

Asked by Dec 05, 2013 at 08:14 AM about the 1999 Volkswagen Cabrio 2 Dr GL Convertible

Question type: Maintenance & Repair

1 Answer

35

Hi, I had a similar issue with mine, I thought it was because I drove through some puddles and soaked the electrics but it continued to get worse as the weeks went by. I had to replace the rotor arm and the distribution cap, I also changed the HT leads while I was at it. Solved the problem. Hope this rules helps.

Your Answer

Add photo

Related Questions

Search Volkswagen Cabrio Questions

Volkswagen Cabrio Experts

#1 Tom Demyan
Tom Demyan
Reputation 4,410
#2 Mike Bonnell
Mike Bonnell
Reputation 1,230
#3 Fkpeach
Fkpeach
Reputation 830
View All

Related Models For Sale

Used Volkswagen Beetle
182 Great Deals out of 9,172 listings starting at $1,950
Used Volkswagen Jetta
550 Great Deals out of 43,843 listings starting at $800
Used Volkswagen GTI
109 Great Deals out of 8,348 listings starting at $1,995
Used Volkswagen Golf
69 Great Deals out of 4,822 listings starting at $1,950
Used Jeep Wrangler
274 Great Deals out of 15,790 listings starting at $3,795
Used Ford Mustang
685 Great Deals out of 44,481 listings starting at $1,500
Used Volkswagen Passat
568 Great Deals out of 24,874 listings starting at $999
Used BMW 3 Series
1,022 Great Deals out of 31,412 listings starting at $1,000
Used Audi A4
309 Great Deals out of 10,498 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.