No power in fuel gauge and pump

Asked by May 07, 2015 at 01:42 AM about the 2000 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

I changed my fuses, and relay. And still no power in the fuel system

1 Answer

10

Check all ground connections. Frame, chassis, body etc. found this issue after replacing a good fuel pump for over $200

1 of 1 people found this helpful.

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,410
  • #2
    Trebor66
    Reputation
    1,030
  • #3
    John Saffrahn
    Reputation
    1,010
View All

Related Models For Sale

Used Chevrolet Silverado 1500
2,123 Great Deals out of 167,340 listings starting at $1,995
Used Ford Ranger
160 Great Deals out of 5,524 listings starting at $1,499
Used GMC Sonoma
6 Great Deals out of 430 listings starting at $1,000
Used Toyota Tacoma
622 Great Deals out of 42,905 listings starting at $1,500
Used Ford F-150
2,316 Great Deals out of 183,061 listings starting at $1,000
Used Chevrolet Blazer
1,050 listings starting at $950
Used Dodge Dakota
123 Great Deals out of 3,729 listings starting at $1,700
Used Nissan Frontier
350 Great Deals out of 21,607 listings starting at $1,796
Used GMC Sierra 1500
896 Great Deals out of 65,451 listings starting at $1,995
Used Dodge Ram 1500
372 Great Deals out of 10,941 listings starting at $1,500
Used Chevrolet Camaro
417 Great Deals out of 30,790 listings starting at $3,550
Used Chevrolet C/K 1500
4 Great Deals out of 842 listings starting at $2,000
Used Ford Mustang
728 Great Deals out of 38,316 listings starting at $895

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.