About once a month my 2000 s-10 with 4.3 v6 wont cold start, i cranck and crank, i smell fuel but wont start, if it does start it runs and starts fine all day. is this a no spark issue

Asked by Dec 02, 2015 at 12:01 PM about the 2000 Chevrolet S-10 2 Dr LS 4WD Extended Cab Stepside SB

Question type: Maintenance & Repair

1 Answer

110,735

have the pump check for proper fuel pressure, also change your fuel filter...

1 of 1 people found this helpful.

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,450
  • #2
    John Saffrahn
    Reputation
    1,040
  • #3
    Trebor66
    Reputation
    1,030
View All

Related Models For Sale

Used Ford Ranger
152 Great Deals out of 5,398 listings starting at $800
Used Chevrolet Silverado 1500
2,244 Great Deals out of 167,963 listings starting at $1,000
Used GMC Sonoma
468 listings starting at $2,100
Used Toyota Tacoma
584 Great Deals out of 43,856 listings starting at $2,200
Used Ford F-150
2,519 Great Deals out of 193,861 listings starting at $799
Used Dodge Dakota
102 Great Deals out of 3,668 listings starting at $1,700
Used Nissan Frontier
357 Great Deals out of 22,770 listings starting at $2,700
Used Chevrolet Blazer
5 Great Deals out of 1,075 listings starting at $950
Used GMC Sierra 1500
1,003 Great Deals out of 66,526 listings starting at $2,495
Used Dodge Ram 1500
368 Great Deals out of 10,765 listings starting at $1,500
Used Chevrolet C/K 1500
858 listings starting at $2,000
Used Chevrolet Camaro
408 Great Deals out of 30,592 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.