I have a 1996 s10 2.2 liter that Ive changed fuel filter & plugs about month ago cause of sputtering and hesitation. The plugs were rusty looking. I put new plugs in 3 days ago andthey r rusty. Why?

Asked by Mar 11, 2015 at 04:28 PM about the 1996 Chevrolet S-10 2 Dr LS Extended Cab SB

Question type: Maintenance & Repair

1 Answer

725

Maybe there was still some rust in the plug hole...? Maybe there is condensation around the plug hole...? Worst scenario, you may have a cracked block..! Check your oil to see if it looks clear and clean.... Is the truck running ok with the new spark plugs ? Let us know, ok?

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,450
  • #2
    John Saffrahn
    Reputation
    1,040
  • #3
    Trebor66
    Reputation
    1,030
View All

Related Models For Sale

Used Ford Ranger
149 Great Deals out of 5,459 listings starting at $800
Used GMC Sonoma
409 listings starting at $2,200
Used Toyota Tacoma
598 Great Deals out of 44,633 listings starting at $1,790
Used Ford F-150
2,581 Great Deals out of 197,077 listings starting at $1,300
Used Dodge Dakota
95 Great Deals out of 3,654 listings starting at $1,750
Used Chevrolet Blazer
3 Great Deals out of 1,071 listings starting at $950
Used GMC Sierra 1500
1,027 Great Deals out of 66,260 listings starting at $1,995
Used Dodge Ram 1500
388 Great Deals out of 10,844 listings starting at $1,500
Used Chevrolet Camaro
442 Great Deals out of 30,819 listings starting at $2,495
Used Chevrolet C/K 1500
869 listings starting at $1,900
Used Chevrolet Tahoe
736 Great Deals out of 41,543 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.