I have a 1996 s10 2.2 liter that Ive changed fuel filter & plugs about month ago cause of sputtering and hesitation. The plugs were rusty looking. I put new plugs in 3 days ago andthey r rusty. Why?

Asked by Mar 11, 2015 at 04:28 PM about the 1996 Chevrolet S-10 2 Dr LS Extended Cab SB

Question type: Maintenance & Repair

1 Answer

815

Maybe there was still some rust in the plug hole...? Maybe there is condensation around the plug hole...? Worst scenario, you may have a cracked block..! Check your oil to see if it looks clear and clean.... Is the truck running ok with the new spark plugs ? Let us know, ok?

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,800
  • #2
    John Saffrahn
    Reputation
    1,110
  • #3
    Trebor66
    Reputation
    1,090
View All

Related Models For Sale

Used Ford Ranger
121 Great Deals out of 4,350 listings starting at $1,500
Used Toyota Tacoma
405 Great Deals out of 47,514 listings starting at $2,994
Used GMC Sonoma
287 listings starting at $2,150
Used Ford F-150
2,230 Great Deals out of 209,288 listings starting at $1,300
Used Dodge Dakota
80 Great Deals out of 3,053 listings starting at $1,495
Used Chevrolet Blazer
697 listings starting at $895
Used GMC Sierra 1500
698 Great Deals out of 60,847 listings starting at $1,395
Used Dodge Ram 1500
320 Great Deals out of 9,388 listings starting at $1,500
Used Chevrolet Camaro
229 Great Deals out of 27,305 listings starting at $2,800
Used Chevrolet C/K 1500
681 listings starting at $2,200
Used Ford Mustang
273 Great Deals out of 37,582 listings starting at $1,350

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.