Chevy S10 4.3 4wd Startup issues

Asked by Dec 15, 2015 at 09:35 AM about the 1995 Chevrolet S-10 2 Dr LS 4WD Extended Cab SB

Question type: General

The engine starts right up when its cold, runs for about five minutes and then
wont idle, i recently changed the coolant sensor it seems to run ruff once it
warms up

1 Answer

20

My s15 did similar when it had moisture in the distributor...worth a quick look under the cap, dry thoroughly, clean contacts if necessary, replace rotor & condenser if they need it...mine had a cracked cap that was replaced as was the whole distributor shaft & everything ...yours could b just a bit of moisture there.

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,780
  • #2
    John Saffrahn
    Reputation
    1,100
  • #3
    Trebor66
    Reputation
    1,080
View All

Related Models For Sale

Used Ford Ranger
121 Great Deals out of 4,569 listings starting at $1,195
Used GMC Sonoma
290 listings starting at $2,150
Used Toyota Tacoma
404 Great Deals out of 45,224 listings starting at $1,995
Used Ford F-150
2,292 Great Deals out of 215,643 listings starting at $1,300
Used Dodge Dakota
72 Great Deals out of 3,047 listings starting at $1,800
Used GMC Sierra 1500
715 Great Deals out of 59,103 listings starting at $1,995
Used Chevrolet Blazer
718 listings starting at $900
Used Dodge Ram 1500
309 Great Deals out of 9,555 listings starting at $1,750
Used Chevrolet C/K 1500
722 listings starting at $800
Used Chevrolet Camaro
240 Great Deals out of 28,859 listings starting at $1,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.