2000 pontiac grand am: my service engine soon light came on had it checked it said my cam shaft position sensor was bad. replaced it ran fine for an hour light came back on..same code. replaced it again...same scenario. any ideas????

25

Asked by Jun 01, 2007 at 08:40 PM about the 2000 Pontiac Grand Am SE

Question type: Maintenance & Repair

1 Answer

29,675

Well either your second cam shaft sensor was bad (not likely) or the sensor is malfunctioning because of an electrical problem.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Pontiac Grand Am Questions

Pontiac Grand Am Experts

#1 tenspeed
tenspeed
Reputation 7,190
#2 John Saffrahn
John Saffrahn
Reputation 1,480
#3 Tom Demyan
Tom Demyan
Reputation 1,280
View All

Related Models For Sale

Used Pontiac Grand Prix
27 Great Deals out of 3,785 listings starting at $1,195
Used Pontiac Firebird
10 Great Deals out of 833 listings starting at $3,800
Used Ford Mustang
718 Great Deals out of 38,848 listings starting at $1,999
Used Chevrolet Impala
997 Great Deals out of 36,594 listings starting at $1,800
Used Chevrolet Monte Carlo
16 Great Deals out of 1,737 listings starting at $1,695
Used Chevrolet Camaro
655 Great Deals out of 39,478 listings starting at $3,495
Used Chevrolet Malibu
1,157 Great Deals out of 80,222 listings starting at $2,495
Used Jeep Grand Cherokee
1,166 Great Deals out of 70,564 listings starting at $495
Used Ford Explorer
1,507 Great Deals out of 73,531 listings starting at $985
Used Chevrolet Cavalier
1,367 listings starting at $1,000
Used Ford Taurus
359 Great Deals out of 22,551 listings starting at $1,499
Used Ford Focus
1,250 Great Deals out of 60,007 listings starting at $1,295