Hello anyone.. I have a 03 Spyder 2.4L it will turn over but won't start up.. I checked the fuel pump n the ignition coils n the wires, n spark plugs.. Also the fuses still not starting up . Sound like it wants to but not getting fire or gas.. Please help I love my car.. Miles are 120,000ish...! Thanks n advance

195

Asked by Jul 14, 2013 at 02:33 AM about the 2003 Mitsubishi Eclipse Spyder GS Spyder

Question type: Maintenance & Repair

Please help me!

49 Answers

112,395

Was it acting funny the last time you drove it? Was the check engine light on?

1 of 1 people found this helpful.
195

Yes the engine light been on before this never got it shut off from prior issue... Any how no problems before I was driving with the ac on, phone on charger, an music playing.. Ok the car just shut of and didn't start back up.. So A tried giving me a jump start.. Nothing.. Then checked all fuses.. NOthing... Ok bought the spray for engine... Nothing. Had my car towed home.. Replaced the ignition coil but that wasn't the problem.. How would u knw if its a censor or timing? Basic can it be fix an will it ever run again, plus stiil would like to knw whatever info u knw about this problem.. I love my Spyder baby! N my Anna Nicole voice...

7 of 7 people found this helpful.
195

O I forgot that maybe two or three days before the driver side floor was wet.. Didn't spill nothing an wasn't raining.. Could that have something to do with it?

5 of 5 people found this helpful.
112,395

It shut itself off or you shut it off with key?

2 of 2 people found this helpful.
112,395

If you were driving the car and it just shut off and will crank over now but just not start I would tend to think timing belt issue. It should have been changed at around the 100000 mile mark. Remove dust cover and inspect belt and tensioner.

3 of 3 people found this helpful.
Best Answer
195

Yes. It shut off on it's own... Yeah u right I going with the timing belt too. We tried everything, now will it ever run again tho..?? Is there any way u can check an see if it is the timing? Im sure your right because I drive alot an I put over 60,000 miles on it in one year... Bad I knw, thanks alot for everything. Im sick without my car

112,395

Hopefully it didn't bend any valves. Will have to check compression on all cylinders to see if that's an issue. You should have between 150 psi to 200 psi on each cylinder. And all should be + - 5 psi of the others. If valves are bent you will show 0 psi for those cylinders. Make sure you change the water pump when you install the new belt. Wife loves hers too.

3 of 3 people found this helpful.
195

Hey hey.. I been tryn to send a picture of mines.. Its nice thanks alot We will try everything.. Will return with results an more questions if so! Thanks a million

195

Im on my phone n can't upload the photo..

1 of 1 people found this helpful.
112,395

Silver. That's a good color too. Good luck and let us know if we can help further.

6,145

you say your driver side floor board is wet ??? sounds like your ecu got wet ,, ive seen this happen before, hopefully you didn't burn it out and is only wet

3 of 3 people found this helpful.
195

Yes Daniel.. Thanks for responding. Tell me more about this ecu and can it be fix also had bad is it either way burnt out or just wet?

1 of 1 people found this helpful.
6,145

just have to open it up see if its wet and let it dry out ... can get it tested somewhere too

2 of 2 people found this helpful.
195

Ok thanks.. Where is it located?

3 of 3 people found this helpful.
6,145

im not sure just know of someone that had a wet console n floor area, and car wouldn't run right then told me that their ecu got wet after it dried out it ran correctly and sounded like yours might be doin the same thing

1 of 1 people found this helpful.
195

Timing belt was the problem guys... Thanks a million for the info my spyder lovers!!! TTakecare (*_*)

6,145

damn that sucks, glad you got it figured out though, was hoping you had a wett ecu like I seen happen before though

195

It does.... Only if I knew about changing the timing belt at 100,000 miles I would have done that to prevent this. Thanks again for the help! Just hope she good for a minute a long minut!

195

Got the belt on car start but missing extremely bad... Plus it was smoke coming from the ignition coil was trying to drive the car but cut off after I put the car in gear started to shaking even harded. Also I turn the ac on and it sounded like it was gonna blow up... Im sooo confuse, can someone tell me any advise about what could be wrong please or if the car would ever run the same again... ??

1 of 1 people found this helpful.
6,145

are you sure did you got the timing correct ??? also did you do a compression test to make sure you didn't bend some vlaves or pop a hole in pistons ??

112,395

Sounds like you have some bent valves. But double check timing marks and tensioner first. If all that is ok the Have a compression check done. You should have between 150 psi and 200 psi on each cylinder and not more than +-5 psi between any of them.

112,395

Any that have 0 psi will have bent valves. I hate to say this but you probably have several bent. But don't give up your car can be repaired and still be a very dependable ride.

195

Still need help.... Spent so much money trying to get this car moving. No hope. It's been in the shop all this time. Fix the timing still was missing now the guy say I need the ecu reset or a new one and no one in the US have a box. Then I went on Ebay and found the box with the code the guy gave mr578588.. Ok basically is it worth me to continue to try or its more to explain but to much to type.. If u can help I glad to give my numbet for more info.. Thanks just get another car I need please any good advice I stuck without my car... Help! Also I have but $900 into this in the last 3weeks

1 of 1 people found this helpful.
112,395

Did he do a compression check? Is check engine light on? If so what are the codes?

6,145

well you can get the current ECU tested and see if its bad but if its missing theres other reasons such as timing is still off or plug wires being in incorrect order coils, ptu, also could be bad or cam sensor etc Is it running but missing ? or cant even get it started ?

1 of 1 people found this helpful.
195

Its running and missing.. It's drivable but trys to cut off when the ever you stop. Stay started as long as you driving missing very bad. Yes the check engine light is still on..

195

I believe the first shop fix thee wrong problem which was never the timing it was always the ecu I'm thinking, but again I nothing about a but to drive n gas.. But thanks forvthe help I give up.. Also They told me the did all of this stuff u been telling me, and my car is stll down n I $900 broker.. Could've been in a new car

6,145

you tested the ecu ??

2 of 2 people found this helpful.
20

please tell me if you got this fixed I have the same problem with my 2001 eclipse its not a spyder. but it will run but misses and jerks and dies when I go up hills or stop. I have already replaced the fuel pump, timing belt, crank censor and pulley and bought a new computer for it and transmission relay. if anyone knows anything else I can do please let me know Ive had it in different shops over the past 7 or 8 months thank you in advance

1 of 1 people found this helpful.
195

Nope went thru four shop's spent $1400 never ran ago I'm driving a 2012 Convertible Mustang now! You'll be lucky for it to run the same again but I think its a wrap... Sorry :( I was sick about my Spider but I'm happy now Good luck girl!

20

thank you anyway! im glad you got you a nice car! yeah its already been so long and still no luck so I figured. do you know anybody that buys broke down cars?

1 of 1 people found this helpful.
195

No problem girlie! Yes call pick n pull they buy broke cars for cheap tho like $300 .... I think you could sell it for more to somebody that fix cars you know post it on Craig and see what you get or call The junk yard for the most you can get! Look at it this way you gottta get you something Bad and New Now!!! :))

112,395

Taraaa. Is your check engine light on?

195

BitchyButch WHAT??

10

I had a similar problem and it ended up being a bad ground connection under the hood from the engine to the car body. It was causing a misfire because there was not enough voltage to fire the fuel injectors,specifically the #4, which had the longest wire. Wonder how many cars have been haoled off for this reason.

1 of 1 people found this helpful.

I have a mitsubishi eclipse v6 3.0 I did the timing belt the water pump spark plugs and still acting up, when I put the scanner it reads cylinder 5&6 can anybody tell me what it can be ?

And also smoke comes from the back of the engine and it smells like is not burning the gas

10

Anyone get this issues fixed? My brother has a Spyder Eclipse. It will turn over but not start. Already replaced distributor, crankshaft sensor, checked timing belt it was good, replaced MAP sensor, none of these things helped. Thinking next to change ECM. Anyone else been there.

1 of 1 people found this helpful.

I have a 2001 2.4 liter manual eclipse that will start but won't turn over. Funny thing it's when I pop start it in gear it runs. And it runs great. I put a new water pump and timing belt on it. So it's not that. It's getting a spark . It's not the injectors, not the battery, not the starter. And after its warned up it starts. But it takes awhile to start. Kinda like the engine its building up momentum then it turns over. But other than that I don't have a clue. Could it be the ecu computer?

195

Yes my problem was the ecu computer... after I replace everything you named above... also she never ran the same after... Good luck! Jimpo1973

Thanks. That's what I thought it was

60

Guys i need help! I have a 01 mitsubishi eclipse 2.4L. One day i was driving when suddendly it shut off on me. It would crank but wont start. Had to tow it back home. At first i did research and i had to replace a the crankshaft sensor and i did but that wasnt the problem. I also keep getting the code P1610 on my scan tool. Battery is good. I tried different test. I removed the fuel pump and gave it direct power and it was working fine. I have no idea whats wrong with it. Any ideas?

5 of 5 people found this helpful.

I need help I have a 2003 eclipse spyder gs convertible it will crank but won't fire so I changed crank shaft sensor ignition coils spark plug wires and still won't start

Don't know what else to do

25

Wow ButchyButch please flush yourself.

1 of 1 people found this helpful.
10

I'm having trouble starting my 2003 Spyder 5speed there's plenty of gas, crank over but will not start :( I though maybe it's because I haven't driven it in 4 days but I have gone a week with out starting her up..

1 of 1 people found this helpful.

My 08 shut down while driving it all the lights came on and lools like radiator is gone. It had never overheated burned oil nothing. Timing belt looks good no water in oil ...HELP!!!

10

The key has a chip in it.If the chip is bad you wount get fuel or fire to the engine. Go to Lowe's or the dealership and have the key tested the chip may have went bad.if you have the owners manual it tells you about this issue.

1 of 1 people found this helpful.
10

Need help with my 2001 Mitsubishi Spyder. Was driving down the road and was losing speed. I went to give it gas but instead of speeding up and went completely down and died. Pulled over in the shoulder and tried starting it. It would crank over but wouldnt start just like if you are running out of gas but i had a full tank. 2 days before this accident happened my stupid brother took off in my car without my knowledge. It started raining and he didnt know how to put the top up so everything in my car got extremely wet. I let it sit in my garage until the day i had this issue when i was on my way to work. Can anyone help me please before I start spending money

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Eclipse Spyder

Looking for a Used Eclipse Spyder in your area?

CarGurus has 491 nationwide Eclipse Spyder listings starting at $1,500.

ZIP:

Search Mitsubishi Eclipse Spyder Questions

Mitsubishi Eclipse Spyder Experts

#1 dandyoun
dandyoun
Reputation 1,740
#2 spyder99
spyder99
Reputation 360
#3 Daniel Foster
Daniel Foster
Reputation 260
View All

Related Models For Sale

Used Mitsubishi Eclipse
28 Great Deals out of 1,319 listings starting at $1,990
Used Ford Mustang
689 Great Deals out of 44,321 listings starting at $1,500
Used Chevrolet Camaro
373 Great Deals out of 31,271 listings starting at $2,500
Used Mazda MX-5 Miata
77 Great Deals out of 3,921 listings starting at $1,800
Used Mitsubishi Lancer Evolution
23 Great Deals out of 521 listings starting at $13,826
Used Chevrolet Corvette
230 Great Deals out of 22,191 listings starting at $3,750
Used Nissan 350Z
55 Great Deals out of 1,209 listings starting at $2,850
Used Mitsubishi Lancer
86 Great Deals out of 6,231 listings starting at $1,677
Used Honda Civic
844 Great Deals out of 83,686 listings starting at $1,200
Used BMW 3 Series
1,001 Great Deals out of 31,467 listings starting at $1,000
Used Jeep Wrangler
282 Great Deals out of 15,781 listings starting at $3,795
Used Honda Accord
1,054 Great Deals out of 66,814 listings starting at $1,000

Used Cars For Sale

2012 Mitsubishi Eclipse Spyder For Sale
3 Great Deals out of 49 listings starting at $6,900
2011 Mitsubishi Eclipse Spyder For Sale
20 listings starting at $6,995
2009 Mitsubishi Eclipse Spyder For Sale
4 Great Deals out of 46 listings starting at $3,790
2008 Mitsubishi Eclipse Spyder For Sale
67 listings starting at $4,899

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.