My 1993 Escort LX only runs when the Mass Airflow Sensor (MAS) is disconnected.

Asked by Jun 11, 2014 at 02:51 PM about the 1993 Ford Escort 4 Dr LX Wagon

Question type: Maintenance & Repair

Car was running fine and then lost power and quit. Fuel pressure and timing belt are fine.  Replacing the MAS didn't help.  Same result. Engine only runs now when MAS is disconnected.  Any ideas about how to diagnose this problem?  Or... what is the consequence of keeping the MAS unplugged?

1 Answer

35

You may have a short in the wiring of the MAF circuit, or it is possible you have the wrong one installed. With the MAF unplugged you will get decreased fuel mileage.

2 people found this helpful.

Your Answer:

Ford Escort Experts

  • #1
    Tom Demyan
    Reputation
    1,110
  • #2
    dandyoun
    Reputation
    940
  • #3
    tennisshoes
    Reputation
    470
View All

Related Models For Sale

Used Ford Mustang
315 Great Deals out of 38,413 listings starting at $1,312
Used Honda Civic
468 Great Deals out of 45,629 listings starting at $1,150
Used Ford Explorer
883 Great Deals out of 66,579 listings starting at $988
Used Ford Fiesta
107 Great Deals out of 16,225 listings starting at $2,789
Used Ford F-150
2,319 Great Deals out of 189,659 listings starting at $1,300
Used Toyota Camry
870 Great Deals out of 71,649 listings starting at $1,300
Used Toyota Corolla
655 Great Deals out of 64,736 listings starting at $1,499
Used Ford Taurus
200 Great Deals out of 15,520 listings starting at $915
Used Ford Crown Victoria
3 Great Deals out of 742 listings starting at $2,000
Used Ford Ranger
105 Great Deals out of 4,236 listings starting at $1,750

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.