2001 Monte Carlo SS hard problem. temp gauge not working

Asked by May 14, 2010 at 10:26 PM about the 2001 Chevrolet Monte Carlo SS

Question type: Maintenance & Repair

Temp gauge was working sometimes. Changed the sensor and the gauge would work.  One morning, I started the car with the gauge working. I drove about 10 minutes and the temp gauge stopped working. I would get to work turn off the engine. After work, the gauge would not be working. After 15 to 20 minutes of driving the gauge would start working again. This lasted for about 2 weeks then the "Low Tire Air" showed on the message center. Just then the temp gauge stopped working all together. Also, when the gauge is not working also the AC does not work. Any help?

1 Answer


did you have the cars computer checked

Your Answer

Chevrolet Monte Carlo Experts

  • #1
  • #2
    Tom Demyan
  • #3
    John Saffrahn
View All

Related Models For Sale

Used Chevrolet Impala
374 Great Deals out of 27,017 listings starting at $1,000
Used Chevrolet Camaro
242 Great Deals out of 30,118 listings starting at $4,980
Used Ford Mustang
291 Great Deals out of 38,369 listings starting at $1,995
Used Pontiac Grand Prix
1,889 listings starting at $2,008
Used Chevrolet Malibu
608 Great Deals out of 48,695 listings starting at $1,800
Used Chevrolet Corvette
86 Great Deals out of 15,794 listings starting at $4,500
Used Buick Regal
108 Great Deals out of 4,193 listings starting at $3,500
Used Chevrolet Silverado 1500
2,199 Great Deals out of 151,084 listings starting at $1,499
Used Chevrolet Tahoe
633 Great Deals out of 37,457 listings starting at $795

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.