I have a 99 Buick century custom I replaced the blower motor in my car cause it made noise and stopped working made no noise at all when I turned on my heat and now I still get nothing checked fuses

Asked by Feb 11, 2015 at 10:11 PM

Question type: Maintenance & Repair

The 25 amp high blower fuse was bad
so I replaced it and still nothing
please help

1 Answer

Replaced the blower motor and resistor and it works now just not on high any suggestions

Your Answer

Add photo

Related Questions

  • what do I check when my heter seems to still work but the blower switch does not? 2 answers

    1989 Buick century, 3.3 1 day the switch just stopped working, could it be a fuse?

    1989 Buick Century Custom Sedan

    -

    Maintenance & Repair

  • 2001 buick century 3 answers

    i was replacing a front turn signal light and when i was doing it my headlights started flashing for about 30 seconds then stopped after i was done replacing the bulb i tried starting the car and it...

    2001 Buick Century Custom

    -

    Maintenance & Repair

  • what could be wrong with my 1999 buick century? 11 answers

    GM 3.1l engine 200k + miles. it was hesitating intermittently about once a month for a while then recently started to develop a rough idle every few days then itd go away and run correctly. eventual...

    1999 Buick Century Custom

    -

    Maintenance & Repair

  • is it a switch or a fuse or a blower motor? 22 answers

    Ok so the other day the blowers stopped blowing and/or making noise. But the heat still comes out very hot just on low it seems no matter how much I turn the fan switch. The back glowed works and th...

    1996 Ford Explorer 4 Dr XLT SUV

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 155,580
#2 FordNut
FordNut
Reputation 105,900
#3 dandyoun
dandyoun
Reputation 86,690
View All