Why isn't my thermostat gauge on the dash working at al in my 89 f150 4X4 XLT Lariat with 5.0L engine its not the theromstat its new and there's no other issues with it overheating but gauge dont work

140

Asked by Jan 12, 2015 at 11:48 PM

Question type: Maintenance & Repair

11 Answers

64,365

Check tempreture sending unit,or wiring to guage.

140

Where is the temperature sending unit at on that engine is there a sensor for it like there is on the 90s chevy trucks

64,365

Yes,should be right at thermostat housing.

64,365

Top radiator hose,follow to housing,should be in it.

140

There's nothing but the hose going back to radiator?

64,365

At motor block,

140

Thermostat is inside there but nothing with any wires showing to possibly b the sensor

64,365

There is a housing going into block,at that ,there will be a sensor.

140

Ill have to look at it again n find out ill b on here throughout the day tomorrow bc i have a few things to figure out with this truck

64,365

If not there ,it will be on the intake somewhere,google it.There are photo,s of it.

140

Ok ill do that thx

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 168,560
#2 dandyoun
dandyoun
Reputation 91,490
#3 tenspeed
tenspeed
Reputation 73,810
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.