I have 79 suburban with a 350 motor and 350 trans it runs fine in park and neutral but in drive and reverse it runs rough any ideas why

Asked by Jun 20, 2013 at 10:32 PM about the 1979 Chevrolet Suburban

Question type: Maintenance & Repair

1 Answer

1,415

lots of things could cause you greif here, I'd guess a miss. So first check or replace your spark plugs and wires, dist cap and rotor. Also be looking for vacuum leaks, broken vacuum lines or broken intake gaskets or carb gaskets. other possibilities are more serious.

Your Answer

Add photo

Related Questions

Search Chevrolet Suburban Questions

Chevrolet Suburban Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 1,010
#2 Eric Fritz
Eric Fritz
Reputation 890
#3 Neal Turner
Neal Turner
Reputation 850
View All

Related Models For Sale

Used Ford F-150
2,058 Great Deals out of 207,340 listings starting at $1,499

Used Cars For Sale

2017 Chevrolet Suburban For Sale
6 Great Deals out of 9,773 listings starting at $41,841
2016 Chevrolet Suburban For Sale
22 Great Deals out of 1,580 listings starting at $36,000
2015 Chevrolet Suburban For Sale
12 Great Deals out of 1,081 listings starting at $22,749
2014 Chevrolet Suburban For Sale
10 Great Deals out of 436 listings starting at $17,500
2013 Chevrolet Suburban For Sale
30 Great Deals out of 602 listings starting at $12,499

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.