starting

Asked by Feb 22, 2010 at 05:33 PM about the 1992 Toyota Previa

Question type: Maintenance & Repair

I have a toyota previa and when I try to start it it just makes a clicking sound. The starter is new and so is the battery. What could be the problem?

1 Answer

210

I had this problem a couple of years ago. It turned out to be my battery cables. I bought the van used and there was corrosion around the terminals. after cleaning them I started having the same problems that you mention. I replaced the battery, starter and ignition. The problem turned out to be corrosion deep inside the battery cables- deep enough that you can't see it. Previa cables are crazy expensive so I would recommend looking for them at a junkyard if that's the source of your problem.

Your Answer:

Toyota Previa Experts

  • #1
    ttdsgnr5
    Reputation
    180
  • #2
    her94previa
    Reputation
    170
  • #3
    gertis
    Reputation
    160
View All

Related Models For Sale

Used Toyota Land Cruiser
16 Great Deals out of 1,150 listings starting at $3,995
Used Toyota 4Runner
252 Great Deals out of 34,349 listings starting at $1,995
Used Honda Civic
352 Great Deals out of 49,702 listings starting at $1,499
Used Toyota Camry
739 Great Deals out of 72,888 listings starting at $1,000
Used Ford F-150
2,230 Great Deals out of 209,288 listings starting at $1,300
Used Honda Accord
540 Great Deals out of 103,313 listings starting at $950
Used Toyota MR2
20 listings
Used Toyota Corolla
592 Great Deals out of 66,412 listings starting at $1,000

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.