when putting key in ignition no power at all, no clicks absolutely nothing..car was perfectly fine 2 hrs previously

Asked by Mar 05, 2008 at 07:27 PM about the 2003 Pontiac Sunfire

Question type: Maintenance & Repair

1 Answer


either you igniition switch just went bad or your Battery is done. Sometimes this happens. Test your battery, should be 12.6-14.4 volts, If you charge the battery and it is fine, It could be your ignition switch. Try and boost the car, If it starts let it run for about 15 min, If you can test the voltage of the battery when it is running, Should be 13.2-14.8 with the car running. Do your lights come on? If they do and your battery is good and your switch is fine. Your altenator might be bad and you ran the battery dead. If you are not sure you might want to take it in and get a "charging system test" done.

1 of 1 people found this helpful.

Your Answer

Pontiac Sunfire Experts

  • #1
    John Saffrahn
  • #2
  • #3
View All

Related Models For Sale

Used Chevrolet Cavalier
641 listings starting at $999
Used Pontiac Firebird
6 Great Deals out of 658 listings starting at $4,999
Used Pontiac Grand Am
760 listings
Used Pontiac Grand Prix
1,902 listings starting at $3,000
Used Ford Mustang
287 Great Deals out of 38,472 listings starting at $1,995
Used Pontiac GTO
3 Great Deals out of 374 listings starting at $3,950
Used Chevrolet Camaro
245 Great Deals out of 30,155 listings starting at $4,980
Used Chevrolet Corvette
107 Great Deals out of 15,743 listings starting at $4,500
Used Nissan Altima
789 Great Deals out of 67,227 listings starting at $750
Used Chevrolet Impala
371 Great Deals out of 27,339 listings starting at $1,499

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.