having problems here I have a 95 3000gt car was working fine on Friday come sunday it wont start. when I turn the ignition on I hear no relays turning on and off and fuel pump dose not prime. all the lights come on and off on the dash. and the fuel pump dose come on when cranking. I do have spark and fuel pressure. would this be a bad main relay or an ecu? I need help

50

Asked by Jun 09, 2013 at 10:46 PM about the 1995 Mitsubishi 3000GT 2 Dr SL Hatchback

Question type: Maintenance & Repair

having problems here I have a 95 3000gt car was working fine on Friday come sunday it wont start. when I turn the ignition on I hear no relays turning on and off and fuel pump dose not prime. all the lights come on and off on the dash. and the fuel pump dose come on when cranking. I do have spark and fuel pressure. would this be a bad main relay or an ecu? I need help

26 Answers

yes, your battery is Kaput...ground connection (the 1/0 battery cable has been compromised with corrosion, wirebrush down to the metal on the chassis and the lug as well, get the bolt and washer clean....on the positive 1/0 cable goin' to the starter solenoid assure solid connecton there as well....five years old is like forcing grandpa to drive in the left lane..it's tough on grampa and the poor traffic that have to deal with him...a five year old battery will push the alternator to a non- solvable output---cooking the alternator....so buy a new battery, interstate, prestolite NAPA get clean ground to frame and engine (yes another 0 gauge 1/0 cable) so startermotor's got enough CCA to get you goin'~

2 out of 2 people think this is helpful.

check the date of your first charge on the knock-off labels on the top...this will be the day that it took it's first charge....five years old= replace me....ten years old = cannot be recharged. be kind to yourself, buy a new battery...you'd have to if you parked near downtown Oakland anyways (in my 15 year experience there)~

1 out of 1 people think this is helpful.
101,825

The fuel pump does not prime on these it will only come on if cam position sensor is turning over. So you do have spark on all plugs?

2 out of 2 people think this is helpful.
101,825

Are your injectors working? How many miles since timing belt changed? Any issues at all last time you drove it?

1 out of 1 people think this is helpful.

he's trying to run in an undervoltage condition...nothin's gonna work dandyoun...okay if he ran with a shurmbacher on there (cannot take a charge anymore) would cook and nothing would happen....jumpstarting could have been an option, but to an undervoltage condition would not be healthy for the electronics involved~

1 out of 1 people think this is helpful.
101,825

Does your car crank over as normal or is it sluggish?

2 out of 2 people think this is helpful.
101,825

Judge you may be right. But tell me how they know they have fire if battery is kaput. That's what's got me. But if infact there is no fire or cranking as normal then the battery and connections are the issues.

good point...partially intuition...partial knowledge of how people won't do anything until it's gonna be too late...take oil changes, you gotta clobber some people just to go in for proper maintainence----a battery....those unpleasant, acidy things....try to forget them if you can.

wonder if redchrisman bothered to look 'pon his batteries birthday~ stoopid, but important this little detail is....I know, I don't like it either~

1 out of 1 people think this is helpful.

no clicks, no fuel pressure dandy...that's kinda the clue...should be~

1 out of 1 people think this is helpful.
50

its a new battery,just cleaned all connections and nothing.new fuel pump,sinding unit, transmission , battery, starter, timing belt, spark plugs and wires.all in the past 6 months. the car was running perfect friday, now nothing. yes spark on all 6 and i power probed the injectors.they are getting power while cranking.

3 out of 3 people think this is helpful.
50

cranks normal as well. even tried jumping the car with another with a few more cables on the ground to make sure there were no grounding issues. i do a lot of work to this myself and regular maintenance is not an issue here.

1 out of 1 people think this is helpful.

hmmm. let's break it down...air----check, fuel----check, ignition---check--- timing...not checked....align your timing marks to see if you've jumped a tooth~

you may have accidentally left the tensioner not cinched down~ that spring may seem like it has enough tension, believe there's an anchor come unanchored~

101,825

Sorry been out of town. You get it going?

redchrisman gave up on us...maybe he drove off smilin'...maybe borrowed someone else's ride by now~

50

hey guys. thanks for everyone's help... after you mentioned the timing I went to go check it that day and it was off... when I took the covers off their was a rip about half way through the belt and each cam was off one way or the other. thank god it didn't start or I would have to be doing a engine swap. I was working on it when y'all posted and would have gotten back sooner but I am now. thanks a lot. PS... don't go for the cheapest timing belt to save a few bucks... not worth it.. got the gates blue belt on ebay for 130. in stores for 240.

1 out of 1 people think this is helpful.
101,825

That's great. Did it start up after you replaced the timing belt? If not do a compression check for bent valves. Your compression should be between 150 and 200 per cyl. Replacing them is not that bad of a job for some one that is handy with tools. Will be a lot cheaper to replace them than swapping an engine in that you will not be sure of its condition.

1 out of 1 people think this is helpful.
175

Im having the same problem. My pump doesnt want to work and my gauge doesnt and the light for low gas doesnt work too. Please help!!

175

My car its a 91 stealth rt tt

sounds like a relay problem, I learned that the fuel pump dose not prime on this car. it only turns on when the cam sensor is picking up signal that the cam is spinning. but for all that to not work at one time I would try a relay, wires going to sending unit, fusses, the sending unit its self. check for voltage on top of unit and through the unit itself. if you have a pick-a-part near you its not to bad I picked up one for $7.00. and check the grounds near and around tank.

My car only has spark on one coil and the other two coils doesn't have anything even though electric is going through help pls

50

check the timing and check the ignition module

50

switch the coils around to rule out bad coils

101,825

Also check for bad plugs. On fouled out plug will cause both on that coil not to fire. What year is yours? How many miles? And do you know how long your timing belt has been in it?

10

Can some one send me a picture of the fuel pump relay and tell me where its located on my 95 3000 gt? My car has fuel, spark, battery, air, timing is set perfectly, and i got 130 lbs of compression per cylinder, and its not wanting to start.. it ran fine last weekend. I just had new valve, new lifters, new guides, new starter, new alternator, new battery, new cv axles, new Macpherson struts, new camshaft position sensor, new crank sensor, new knock sensor, it practically a new car.. turns over but wont start.. when i unplug the starter solenoid you can hear the fuel pump prime, when you plug the starter solenoid, you hear no prime from the fuel pump.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

3000GT

Looking for a Used 3000GT in your area?

CarGurus has 97 nationwide 3000GT listings starting at $3,495.

ZIP:

Search Mitsubishi 3000GT Questions

Mitsubishi 3000GT Experts

#1 dandyoun
dandyoun
Reputation 2,430
#2 Daniel Foster
Daniel Foster
Reputation 820
#3 T_S_T
T_S_T
Reputation 260
View All

Related Models For Sale

Used Mitsubishi Eclipse
47 Great Deals out of 1,541 listings starting at $1,495
Used Mitsubishi Lancer Evolution
14 Great Deals out of 695 listings starting at $11,990
Used Ford Mustang
718 Great Deals out of 39,150 listings starting at $1,000
Used Nissan 300ZX
150 listings
Used Toyota Supra
38 listings starting at $56,900
Used Chevrolet Camaro
630 Great Deals out of 39,689 listings starting at $2,995
Used Chevrolet Corvette
367 Great Deals out of 20,434 listings starting at $3,688
Used Dodge Stealth
48 listings
Used Mazda RX-7
57 listings
Used Acura NSX
187 listings starting at $34,995
Used Pontiac Firebird
12 Great Deals out of 842 listings starting at $3,800
Used BMW M3
75 Great Deals out of 2,182 listings starting at $3,495
Used Mitsubishi Eclipse Spyder
15 Great Deals out of 650 listings starting at $1,969