1992 Lincoln Mark VII

Asked by Jun 18, 2016 at 07:05 PM about the 2000 Lincoln LS V8

Question type: Maintenance & Repair

I washed engine off one week ago on my Lincoln ,
1992 Mark VII and it drove fine afterwards. The
next day it would not start.The Battery is fine, after
having to charge it. What else could it be ?

1 Answer

you probably got a sensor wet. The engine bay will need to dry out and you should be fine again....hopefully.

Your Answer

Lincoln LS Experts

  • #1
    Ionatan Ion
    Reputation
    1,230
  • #2
    Tom Demyan
    Reputation
    910
  • #3
    Jonathon Sheffield
    Reputation
    750
View All

Related Models For Sale

Used Ford Mustang
770 Great Deals out of 42,663 listings starting at $1,300
Used Lincoln Town Car
38 Great Deals out of 1,779 listings starting at $1,495
Used Ford Taurus
249 Great Deals out of 17,805 listings starting at $1,499
Used Lincoln Continental
10 Great Deals out of 4,553 listings starting at $36,951
Used Honda Accord
1,046 Great Deals out of 63,026 listings starting at $999
Used Chevrolet Impala
598 Great Deals out of 34,726 listings starting at $1,250
Used BMW 3 Series
1,048 Great Deals out of 31,680 listings starting at $1,000
Used Nissan Maxima
323 Great Deals out of 23,728 listings starting at $1,550
Used Lincoln Navigator
96 Great Deals out of 5,080 listings starting at $1,900

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.