Ford Windstar, 1999 strange rear light issues

20

Asked by Apr 04, 2015 at 07:17 PM about the 1999 Ford Windstar 4 Dr SE Passenger Van

Question type: Maintenance & Repair

On the Drivers side, the tail light doesn't work but the break light does. On the Passenger
side, the taillight works but the break light doesn't. WTF??? Any professional opinion?

Possibly relevant info: All fuses checked,  battery is 12 years old (getting a new one), and
the bulb on the drivers side is a universal bulb. Please help

1 Answer

42,375

The bulbs should have double filaments. You probably have a broken filament on either side. Just the exact opposite. Bulb will not be black. Very hard to see a broken filament.

Your Answer

Ford Windstar Experts

  • #1
    JohnBarJB
    Reputation
    590
  • #2
    T_S_T
    Reputation
    460
  • #3
    Tom Demyan
    Reputation
    420
View All

Related Models For Sale

Used Chrysler Town & Country
335 Great Deals out of 13,635 listings starting at $1,000
Used Toyota Sienna
461 Great Deals out of 26,020 listings starting at $1,250
Used Dodge Grand Caravan
376 Great Deals out of 26,314 listings starting at $1,750
Used Honda Odyssey
441 Great Deals out of 30,391 listings starting at $1,000
Used Ford Explorer
1,025 Great Deals out of 70,284 listings starting at $2,100
Used Ford F-150
2,772 Great Deals out of 212,018 listings starting at $1,300
Used Dodge Caravan
582 listings starting at $2,499
Used Honda Accord
1,067 Great Deals out of 65,536 listings starting at $561
Used Ford Focus
713 Great Deals out of 57,226 listings starting at $1,150
Used Nissan Quest
80 Great Deals out of 2,898 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.