When I try to get in the gas I loose power

Asked by May 23, 2017 at 07:54 PM about the 1996 Chevrolet C/K 1500 Cheyenne Extended Cab LB 4WD

Question type: Maintenance & Repair

I have a 1996 chevy 1500 with the 5.7 and the
4l60e transmission just got it rebuilt and now when
the truck is running at an idle in park and Rev it up
everything sounds good but when I start driving
and try to take off fast it seems like it looses power
, but if you give it gas slowly it will go fine any ideas

1 Answer


Was any part of the fuel delivery system changed? May have a plugged fuel filter, or the fuel pump is weak, and lastly a problem with the spider injection assembly. Check the fuel pressure with a fuel pressure gauge at the Schrader Valve, it should be 56 to 63 lbs. and rev. up the engine to see if it holds the proper fuel pressure.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
  • #2
    John Saffrahn
  • #3
View All

Related Models For Sale

Used GMC Sierra 1500
908 Great Deals out of 59,399 listings starting at $1,980
Used Ford F-150
2,535 Great Deals out of 221,934 listings starting at $1,222
Used Chevrolet C/K 2500
200 listings starting at $3,495
Used Dodge Ram 1500
342 Great Deals out of 9,663 listings starting at $800
Used Chevrolet Tahoe
646 Great Deals out of 37,897 listings starting at $695
Used Chevrolet Camaro
257 Great Deals out of 30,437 listings starting at $4,200
Used Toyota Tacoma
452 Great Deals out of 41,046 listings starting at $2,600
Used Chevrolet C/K 3500
181 listings starting at $6,990
Used Chevrolet S-10
11 Great Deals out of 1,051 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.