heater switces not working, only once in aq while what to repalce?

Asked by Feb 26, 2014 at 11:16 PM about the 2000 Cadillac DeVille Base

Question type: Maintenance & Repair

try to turn heater fan on some times it works, most times it wont

1 Answer

41,925

Sounds like your blower motor is bad. If you have no fan at all, it would be your blower motor. If you have only one speed all the time, it would most likely be your blower motor resistor. For a quick test, turn on your fan, if no fan comes on, take a hammer and tap on the bottom of your blower motor. If it suddenly come on, the brushes are bad in your motor. Usually located under passenger side glove box. Here's a quick video: http://www.youtube.com/watch?v=ymKzKOnI78s

2 of 2 people found this helpful.

Your Answer

Cadillac DeVille Experts

  • #1
    kikero
    Reputation
    2,220
  • #2
    Js08016
    Reputation
    1,940
  • #3
    Cynthiasmith
    Reputation
    1,670
View All

Related Models For Sale

Used Cadillac Seville
322 listings starting at $1,999
Used Lincoln Town Car
42 Great Deals out of 1,771 listings starting at $1,000
Used Chevrolet Impala
539 Great Deals out of 35,140 listings starting at $900
Used Cadillac Escalade
253 Great Deals out of 12,099 listings starting at $2,500
Used Mercedes-Benz S-Class
148 Great Deals out of 7,092 listings starting at $2,888
Used Chevrolet Camaro
430 Great Deals out of 30,655 listings starting at $1,450
Used Ford Mustang
588 Great Deals out of 36,178 listings starting at $1,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.