91 silverdro ,cranks,no fuel at tbi ,new pump,all fuses good oil level good have to turn over a lot to get it to run

Asked by Apr 12, 2017 at 01:34 PM about the 1991 Chevrolet C/K 1500 Silverado Extended Cab LB

Question type: General

no run ,will not start ,no fuel ,new pump

7 Answers

74,775

So how do you figure there is no fuel. Are you trying to start it and watching the injectors to see if fuel is spraying out? Fuel will not come out unless the key is in the start position and then running. Have you checked for spark? And do you hear the fuel pump prime up when you turn the key to the on position?

have spark when engine is turning over takes a long time turning over then it starts ,supect eather oil swith or bad relay ,been doing this for over 50 yr this one is for the books , thanks

74,775

Can't help without details, like has the fuel regulator ben rebuilt in the TBI? Fuel pressure should be 9 to 13 lbs. Have you looked at the injectors to see if it is a nice cone shape spray mist coming out when it is running? With no drips at all from the injectors?

1 of 1 people found this helpful.

i rebuilt the tbi unit almost 6 mo age ,works fine withe engine running ,if the truck starts it runs fine ,no proublem ,plenty of speed ,shut it off ,go in a store and it takes a long time turning over before it fires up ,get out of the truck ,remove air cleaner ,have wife try to start it no spray at the injectors ,turn key off ,try to start it again ,same proublem ,no fuel spray,set 5min it will start ,new tank ,new pump with out cap on tank ,no differnt ,no restrictions in fuel line ,thanks guy wife s truck ,help

74,775

So, what it is for what ever reason, there is no injector pulse when your cranking on it at first. When the key is in the start position the fuel injectors should be spraying fuel down into the intake. Why it is not is what has to be investigated.

1 of 1 people found this helpful.

thanks i will replace the manfold sener tomorrow ,let you know how we do ,thanks

Had the same problem with a 94 I just got. It was the pulse module in the distributor. It seemed 2 b brand new, but a tin plate had bin installed on top of the module(can u say stupid), and there was a great deal of corrosion around the module and on the base plate. Took it apart, cleaned it up, applied a thin film of Vaseline between the base plate and the mateing surface of the module, put it back 2gether minus the piece of tin that was on top of the module, reinstalled the distributor, reset the timing(of course), and walla, turned over quickly, and is still running fine. Can't remember where I read that.

Your Answer

C/K 1500

Looking for a Used C/K 1500 in your area?

CarGurus has 881 nationwide C/K 1500 listings starting at $1,900.

ZIP:

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,720
  • #2
    John Saffrahn
    Reputation
    2,600
  • #3
    Rowefast
    Reputation
    2,200
View All

Related Models For Sale

Used GMC Sierra 1500
1,014 Great Deals out of 66,368 listings starting at $2,495
Used Ford F-150
2,574 Great Deals out of 199,192 listings starting at $1,300
Used Chevrolet C/K 2500
203 listings starting at $3,994
Used Chevrolet Camaro
444 Great Deals out of 30,843 listings starting at $1,450
Used Chevrolet C/K 3500
3 Great Deals out of 238 listings starting at $1,500
Used Chevrolet S-10
20 Great Deals out of 1,251 listings starting at $1,600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.