Not starting after it ran extremely rough before was missing and had almost no power

Asked by Sep 13, 2015 at 08:18 PM about the 1996 Chevrolet C/K 1500 Cheyenne Standard Cab SB 4WD

Question type: Maintenance & Repair

Changed plugs but not the wires
changed cam sensor fuel pump and
filter distributor cap and rotor they are
in good condition not sure what else
to check need some ideas it also has
a code for the throttle position sensor
after i unplugged it to clean it no sure
how to reset it

1 Answer

MAF sensor..

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,720
  • #2
    John Saffrahn
    Reputation
    2,600
  • #3
    Rowefast
    Reputation
    2,200
View All

Related Models For Sale

Used GMC Sierra 1500
999 Great Deals out of 66,240 listings starting at $2,495
Used Ford F-150
2,563 Great Deals out of 195,337 listings starting at $1,300
Used Chevrolet C/K 2500
213 listings starting at $6,495
Used Dodge Ram 1500
356 Great Deals out of 10,824 listings starting at $1,500
Used Chevrolet Tahoe
719 Great Deals out of 41,409 listings starting at $1,995
Used Chevrolet Camaro
433 Great Deals out of 30,716 listings starting at $2,495
Used Chevrolet C/K 3500
229 listings starting at $3,999
Used Chevrolet S-10
18 Great Deals out of 1,247 listings starting at $1,600
Used Toyota Tacoma
575 Great Deals out of 44,301 listings starting at $2,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.