changed oxygen sensors, wires, plugs, car runs poorly when warmed up could problem be mass air sensor on 2002 buick lasabrec

Asked by Oct 31, 2013 at 09:41 AM about the 2002 Buick LeSabre Custom Sedan FWD

Question type: Maintenance & Repair

car ran great until recently ran good when i started up after new parts but started running bad and almost stalling when warmed up

1 Answer

25

Check your IAC Valve. Could be bad and causing the bad idle.

Your Answer:

Buick LeSabre Experts

  • #1
    Tom Demyan
    Reputation
    2,480
  • #2
    John Saffrahn
    Reputation
    2,200
  • #3
    Austin Gaboda
    Reputation
    1,510
View All

Related Models For Sale

Used Buick Park Avenue
288 listings starting at $2,600
Used Chevrolet Impala
384 Great Deals out of 25,757 listings starting at $950
Used Buick Regal
91 Great Deals out of 3,929 listings starting at $5,300
Used Buick Century
535 listings starting at $3,995
Used Honda Accord
566 Great Deals out of 103,985 listings starting at $950
Used Cadillac DeVille
1,263 listings starting at $2,000
Used Chevrolet Malibu
489 Great Deals out of 51,744 listings starting at $1,995
Used Toyota Camry
759 Great Deals out of 73,415 listings starting at $1,195
Used Lincoln Town Car
28 Great Deals out of 1,469 listings starting at $1,900
Used Ford Taurus
184 Great Deals out of 15,879 listings starting at $600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.