changed oxygen sensors, wires, plugs, car runs poorly when warmed up could problem be mass air sensor on 2002 buick lasabrec

Asked by Oct 31, 2013 at 09:41 AM about the 2002 Buick LeSabre Custom

Question type: Maintenance & Repair

car ran great until recently ran good when i started up after new parts but started running bad and almost stalling when warmed up

1 Answer

25

Check your IAC Valve. Could be bad and causing the bad idle.

Your Answer

Add photo

Search Buick LeSabre Questions

Buick LeSabre Experts

#1 Tom Demyan
Tom Demyan
Reputation 1,970
#2 John Saffrahn
John Saffrahn
Reputation 1,650
#3 POPEYE99
POPEYE99
Reputation 1,350
View All

Related Models For Sale

Used Buick Park Avenue
511 listings starting at $1,400
Used Chevrolet Impala
793 Great Deals out of 34,384 listings starting at $799
Used Buick Regal
123 Great Deals out of 10,947 listings starting at $1,850
Used Buick Century
1,070 listings starting at $3,300
Used Honda Accord
811 Great Deals out of 81,613 listings starting at $899
Used Cadillac DeVille
6 Great Deals out of 1,953 listings starting at $1,750
Used Chevrolet Malibu
1,006 Great Deals out of 85,672 listings starting at $1,995
Used Pontiac Grand Prix
28 Great Deals out of 3,715 listings starting at $1,100
Used Ford Taurus
254 Great Deals out of 20,514 listings starting at $1,500
Used Nissan Maxima
347 Great Deals out of 25,223 listings starting at $1,400
Used Lincoln Town Car
29 Great Deals out of 2,080 listings starting at $1,995
Used Mercury Grand Marquis
26 Great Deals out of 2,202 listings starting at $1,995