Why do both lights stay on when the 4 wheel drive is engaged? sometimes it does not go in the lights

35

Asked by Mar 09, 2008 at 10:07 AM about the 1994 Chevrolet S-10 Blazer 4 Dr Tahoe 4WD SUV

Question type: Maintenance & Repair

When I try to put the 4 wheel drive the switch will blink. then both lights will stay on and i don't know if its in high or low 4 wheel drive. some times it just blinks and does not engage at all. whY?

2 Answers

42,925

Sounds like the vacuum/electrical switch that kicks over the 4WD is going out. I would take this to a mechanic and have it checked out. It's not a hard or expensive fix but it could be either wiring related or switch related.

1 out of 1 people think this is helpful.
655

this propblem can be caused by 1 the encoder motor/transfercase motor 2 the transfercase switch 3 vaccum actuator under battery tray 4 broken cable from actuator to front diff. now we know the possible problems lets check them individualy fist the encoder motor when your in nutral and press the 4hi button does it flash and just never go in? can you hear an electric motor? after you press 4hi get undernieth the blazer and check if you can turn the front drive shaft by hand? in not this is a good thing and means your transfercase is locked in four wheel drive. if you can turn the drive shaft by hand i would replace the encodermotor (any where from 130$-150$ at a parts store and you do the work your self second is testing the vaccum lines after your transfer case is locked there is one line going from the back of the plenium to the switch on top of the transfercase when the engine is running it should have vaccum when you put it in 4hi it switches the switch and provides vaccum to the front actuator under the batery tray (this is the hose i think one of the privious posters talked about) make sure there is vaccum to the hose when in four wheel drive and if there is no vaccum i would replace the vaccum switch (10$-20$ at parts store and you do the work your self) if there is vaccum then you need to test the actuator it self you should be able to see it move when 4wheel drive is turnd on and off if it dont move the diphram could be tore and if it does move then very very very unliky your cable from the actuator to the front differntial is broken and i dont know what would be wrong hope this helps let us know when/if you fix it *the picture is of the actuator under the tray p.s dont listen to the post before me i would fix it myself if i was you

3 out of 3 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,440
#2 Cody Doud
Cody Doud
Reputation 610
#3 emtfirefighter77
emtfirefighter77
Reputation 330
View All

Related Models For Sale

Used Chevrolet S-10
8 Great Deals out of 1,333 listings starting at $1,395
Used Chevrolet Blazer
3 Great Deals out of 1,154 listings starting at $500
Used Chevrolet Camaro
205 Great Deals out of 30,790 listings starting at $1,217
Used GMC Jimmy
257 listings starting at $2,495
Used Ford F-150
2,231 Great Deals out of 205,275 listings starting at $1,499
Used Dodge Ram 1500
469 Great Deals out of 11,116 listings starting at $700
Used Chevrolet C/K 1500
897 listings starting at $2,500
Used GMC Sonoma
6 Great Deals out of 468 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.