no power

Asked by Dec 20, 2014 at 03:06 PM about the 2000 Toyota ECHO 2 Dr STD Coupe

Question type: Maintenance & Repair

our 2 dr automatic echo has no power.  had a scan run; changed plugs per suggestion,
didnt help.  it barely crawls along, til about 5 miles or so; then seems ok. could it be fuel
filter? fuel pump? this was never an issue til cold weather set in.  any help is GREATLY
appreciated! thanks in advance!

1 Answer

145

The scan came up with no codes? What sort of mileage on the car. When you say 5 miles, do you mean speed of after driving for a little bit it clears up(engine gets warm). It is less likely to be a pump or filter as cold weather seems to have triggered it. Likely a sensor is bad giving false information when cold.

Your Answer:

Toyota ECHO Experts

  • #1
    Tom Demyan
    Reputation
    110
  • #2
    schalk
    Reputation
    80
  • #3
    LouB
    Reputation
    70
View All

Related Models For Sale

Used Toyota Yaris
48 Great Deals out of 2,452 listings starting at $1,800
Used Toyota Corolla
623 Great Deals out of 66,697 listings starting at $900
Used Honda Civic
376 Great Deals out of 49,269 listings starting at $1,499
Used Toyota Camry
759 Great Deals out of 73,415 listings starting at $1,195
Used Toyota Prius
152 Great Deals out of 17,884 listings starting at $1,000
Used Toyota RAV4
526 Great Deals out of 79,409 listings starting at $1,995
Used Toyota Celica
248 listings starting at $2,995
Used Hyundai Accent
250 Great Deals out of 12,630 listings starting at $1,250
Used Toyota Tacoma
422 Great Deals out of 48,089 listings starting at $2,994
Used Honda Accord
566 Great Deals out of 103,986 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.