no power

Asked by Dec 20, 2014 at 03:06 PM about the 2000 Toyota ECHO 2 Dr STD Coupe

Question type: Maintenance & Repair

our 2 dr automatic echo has no power.  had a scan run; changed plugs per suggestion,
didnt help.  it barely crawls along, til about 5 miles or so; then seems ok. could it be fuel
filter? fuel pump? this was never an issue til cold weather set in.  any help is GREATLY
appreciated! thanks in advance!

1 Answer

85

The scan came up with no codes? What sort of mileage on the car. When you say 5 miles, do you mean speed of after driving for a little bit it clears up(engine gets warm). It is less likely to be a pump or filter as cold weather seems to have triggered it. Likely a sensor is bad giving false information when cold.

Your Answer

Add photo

Related Questions

Search Toyota ECHO Questions

Toyota ECHO Experts

#1 Tom Demyan
Tom Demyan
Reputation 90
#2 Delta_Pacer
Delta_Pacer
Reputation 50
#2 LouB
LouB
Reputation 50
View All

Related Models For Sale

Used Toyota Corolla
662 Great Deals out of 71,905 listings starting at $600
Used Toyota Yaris
94 Great Deals out of 5,292 listings starting at $2,245
Used Honda Civic
503 Great Deals out of 87,905 listings starting at $1,499
Used Toyota Camry
790 Great Deals out of 89,572 listings starting at $950
Used Toyota Celica
366 listings starting at $1,995
Used Toyota Prius
159 Great Deals out of 17,500 listings starting at $1,771
Used Toyota RAV4
585 Great Deals out of 69,403 listings starting at $2,350
Used Hyundai Accent
165 Great Deals out of 12,621 listings starting at $1,888
Used Toyota Tacoma
481 Great Deals out of 39,055 listings starting at $2,900
Used Honda Accord
705 Great Deals out of 87,160 listings starting at $699