I have a 2000 Monte Carlo and I have replaced the fan sensors the water pump intake gaskets the radiator hoses the thermostat and it is still overheating!! Can someone help me !! Wats wrong

130

Asked by Dec 10, 2015 at 09:36 PM

Question type: Maintenance & Repair

6 Answers

70,195

I see you have replaced most of the coolant system,but the radiator it self,if it is not the issue and your coolant fans are working right,you may have head issue,s.

130

How can I tell if it's the radiator? And wouldn't they be water in my oil if it's a head problem? The car will idle for ever and it drove for 10 miles and it shot the radiator sensor out! Could it be just the sensor on the radiator or do I need a new radiator?

1 of 1 people found this helpful.
70,195

I am thinking new radiator,

70,195

Are you sure the coolant fans are working?

130

Yeah they kick on! And other times the it pops out the sensor and the engine isn't even hot!

1 of 1 people found this helpful.
70,195

If you can fix the sensor to stay in,you may be all right,but if not replace the radiator should fix your issue.

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    186,170
  • #2
    dandyoun
    Reputation
    97,270
  • #3
    tennisshoes
    Reputation
    82,470
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.