Something in my 96 deville is draining my battery overnight had it diagnosed an my starter an alternator are working properly so what's wrong...sweet tea did get spilt in my radio could that be a problem? Plz help

Asked by Nov 20, 2012 at 09:50 PM

Question type: Maintenance & Repair

4 Answers

246,475

the tea in the radio might be. One way to eliminate the doubt would be to remove the radio and see if the issue goes away.

6,665

The tea probably created a circuit and now electricity is being drawn. I have had this problem with a few fords of mine... It is usually just a dirty connection. A multimeter will help you locate the problem. If the car has a factory amp, sometimes those drain the battery too.

So do I just take the whole radio out an then it will stop or do I need to take it to a dealership an have them fix it

6,665

If you could take the radio out yourself that would be great... There's no guarantee's that it will fix your problem (Its just a test). Don't bring it to a dealer unless you're made of money.

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 174,560
#2 dandyoun
dandyoun
Reputation 93,430
#3 tennisshoes
tennisshoes
Reputation 75,940
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.