im losing battery charge. Its has a new battery and alternator. Why am i losing power?

Asked by Apr 26, 2016 at 01:36 PM about the 1967 Chevrolet C/K 10

Question type: Maintenance & Repair

5 Answers

1,530

check your alternator.. maybe alternator not charging..

1 of 1 people found this helpful.

Its brand new as well.

12,615

Probably a parasitic draw, why did you change the Alternator no output? was it bench tested or did you check it at the battery for 13.2-14.8volts..how long does it take to discharge the battery overnight or in minutes or hours? I suggest checking ALL grounds and connections AGAIN

1 of 1 people found this helpful.

the battery has some charge. The lights turn on. Not enough charge to turn the trunk on. it turns over very slow.

12,615

If your not sure how to check or do some basic testing, with a multimeter or don't have one. It's best to have it looked at. You can spend a lot time guessing. Tell the shop you want 1.The battery load tested. 2.The alternator output checked 3. check for parasitic battery (draw) drain. 4.starter circuit voltage drop test . ASK HOW MUCH

Best Answer

Your Answer

Add photo

Related Questions

C/K 10

Looking for a Used C/K 10 in your area?

CarGurus has 278 nationwide C/K 10 listings and the tools to find you a great deal.

ZIP:

Search Chevrolet C/K 10 Questions

Chevrolet C/K 10 Experts

#1 CaptPKelly
CaptPKelly
Reputation 680
#2 Rowefast
Rowefast
Reputation 370
#3 F_O_R
F_O_R
Reputation 360
View All

Related Models For Sale

Used Chevrolet Camaro
349 Great Deals out of 31,370 listings starting at $2,500
Used Ford F-100
162 listings
Used Ford Mustang
716 Great Deals out of 44,997 listings starting at $1,500
Used Chevrolet Corvette
209 Great Deals out of 22,044 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.