My temperature garage works sometimes, have already replaced sending unit, but still does it. The odometer is doing same thing. what could problem be?

Asked by Dec 29, 2015 at 07:16 AM about the 1996 Ford Contour

Question type: Maintenance & Repair

1 Answer

69,655

The temp sending unit has nothing to do with the odometer other than the gauge. There should be a fuse to check. The temperature readings you are getting, may be low coolant, bad thermostat, or air pockets in the cooling system.

Your Answer

Add photo

Related Questions

Search Ford Contour Questions

Ford Contour Experts

#1 tropikalpirate
tropikalpirate
Reputation 630
#2 David Koppa
David Koppa
Reputation 330
#3 Wesley Beadle
Wesley Beadle
Reputation 280
View All

Related Models For Sale

Used Ford F-150
2,198 Great Deals out of 206,316 listings starting at $1,499
Used Ford Escort
334 listings
Used Ford Crown Victoria
12 Great Deals out of 1,069 listings starting at $2,995
Used Ford Mustang
474 Great Deals out of 45,735 listings starting at $1,999
Used Ford Taurus
250 Great Deals out of 20,434 listings starting at $699
Used Toyota Camry
1,006 Great Deals out of 90,918 listings starting at $650
Used Nissan Maxima
305 Great Deals out of 25,213 listings starting at $999
Used Toyota Corolla
783 Great Deals out of 73,832 listings starting at $1,995
Used Honda Civic
656 Great Deals out of 88,604 listings starting at $995
Used Chevrolet Camaro
226 Great Deals out of 30,943 listings starting at $1,217

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.