I have a 1994 c280 Mercedes Benz the problem I'm having is when I jump start the car it runs but when I put my foot on the gas for it to accelerate it shuts off. What is worng

Asked by Nov 07, 2014 at 08:43 PM about the 1994 Mercedes-Benz 280

Question type: Maintenance & Repair

2 Answers

75,205

Sound,s like,battery may be bad,or alternator may not be charging right,if both of these are good ,you may want to check the fuel pressure,may be bad fuel pump.

1 people found this helpful.
23,325

if your jumping from another battery and it runs good that's because you have a full 12 volts. when removing the jumper you may have a low battery and a weak alternator with too low voltage to operate the pmc.

Your Answer:

Mercedes-Benz 280 Experts

  • #1
    Mick Stewart
    Reputation
    160
  • #2
    tenspeed
    Reputation
    80
  • #3
    Paul Matthews
    Reputation
    60
View All

Related Models For Sale

Used Mercedes-Benz SL-Class
52 Great Deals out of 3,011 listings starting at $2,999
Used Mercedes-Benz 300-Class
169 listings starting at $3,995
Used Mercedes-Benz C-Class
669 Great Deals out of 26,278 listings starting at $1,812
Used Mercedes-Benz S-Class
149 Great Deals out of 6,994 listings starting at $3,495
Used Mercedes-Benz E-Class
436 Great Deals out of 19,900 listings starting at $1,995
Used Porsche 911
83 Great Deals out of 4,770 listings starting at $9,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.