Battery problems

Asked by Jan 04, 2017 at 06:38 PM about the 2003 Oldsmobile Alero GL Coupe

Question type: Maintenance & Repair

Cold weather has made it difficult to start my car.
Twice it has been dead and it started right away
with a jump. Today when it wouldn't start I popped
the hood and shook the battery a little and it
started. All connections seemed ok So I'm
wondering what else may cause this

1 Answer

87,155

More than likely the battery needs replacing. Also the charging system needs to be checked out. If you had a digital multi-meter you could check to see if it is putting out 14.5V at the battery when the car is running.

1 people found this helpful.

Your Answer:

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    620
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Rowefast
    Reputation
    220
View All

Related Models For Sale

Used Pontiac Grand Am
730 listings starting at $2,200
Used Honda Civic
522 Great Deals out of 40,951 listings starting at $1,615
Used Chevrolet Impala
544 Great Deals out of 25,503 listings starting at $790
Used Chevrolet Malibu
635 Great Deals out of 53,109 listings starting at $1,300
Used Honda Accord
683 Great Deals out of 97,845 listings starting at $750
Used Toyota Corolla
687 Great Deals out of 60,523 listings starting at $1,499
Used Pontiac Grand Prix
16 Great Deals out of 1,679 listings starting at $1,350
Used Nissan Altima
938 Great Deals out of 54,374 listings starting at $1,300

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.