Left side of Instrument Cluster Lights dont work but the right side does.

Asked by May 23, 2014 at 05:31 PM about the 1999 Mercury Cougar 2 Dr V6 Hatchback

Question type: Maintenance & Repair

I recently bought a 99 Cougar. There are a few issues with it, but it runs ok for right now. What i am concerned about is the left side of Instrument Cluster Lights in the dash dont light up at all. The right side does work though. Ive checked all the fuses n the driver side and under the hood. They all are fine. Can anyone help with this?

2 Answers

121,095

Could be loose connection or blown bulbs.

You need to remove the IP - and then get to the back of the speedo and idiot lights ...

Your Answer

Mercury Cougar Experts

  • #1
    lisagayle
    Reputation
    2,240
  • #2
    Tom Demyan
    Reputation
    820
  • #3
    Jessica Cornelison
    Reputation
    610
View All

Related Models For Sale

Used Ford Mustang
255 Great Deals out of 36,632 listings starting at $2,500
Used Mercury Grand Marquis
23 Great Deals out of 1,206 listings starting at $1,200
Used Chevrolet Camaro
241 Great Deals out of 28,690 listings starting at $1,800
Used Chevrolet Corvette
97 Great Deals out of 15,310 listings starting at $3,900
Used Chevrolet Impala
385 Great Deals out of 25,583 listings starting at $900
Used Pontiac Firebird
8 Great Deals out of 675 listings starting at $3,695
Used Ford F-150
2,283 Great Deals out of 215,032 listings starting at $1,300
Used Chevrolet Malibu
448 Great Deals out of 49,711 listings starting at $2,111

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.