Left side of Instrument Cluster Lights dont work but the right side does.

Asked by May 23, 2014 at 05:31 PM about the 1999 Mercury Cougar 2 Dr V6 Hatchback

Question type: Maintenance & Repair

I recently bought a 99 Cougar. There are a few issues with it, but it runs ok for right now. What i am concerned about is the left side of Instrument Cluster Lights in the dash dont light up at all. The right side does work though. Ive checked all the fuses n the driver side and under the hood. They all are fine. Can anyone help with this?

2 Answers

114,245

Could be loose connection or blown bulbs.

You need to remove the IP - and then get to the back of the speedo and idiot lights ...

Your Answer

Mercury Cougar Experts

  • #1
    lisagayle
    Reputation
    2,200
  • #2
    Tom Demyan
    Reputation
    790
  • #3
    Jessica Cornelison
    Reputation
    600
View All

Related Models For Sale

Used Ford Mustang
713 Great Deals out of 38,332 listings starting at $895
Used Chevrolet Corvette
298 Great Deals out of 20,714 listings starting at $2,990
Used Chevrolet Camaro
427 Great Deals out of 30,917 listings starting at $3,550
Used Mercury Grand Marquis
35 Great Deals out of 1,768 listings starting at $1,950
Used Pontiac Firebird
12 Great Deals out of 777 listings starting at $2,999
Used Ford F-150
2,325 Great Deals out of 184,534 listings starting at $699
Used Chevrolet Impala
523 Great Deals out of 34,216 listings starting at $950
Used Mercedes-Benz C-Class
653 Great Deals out of 26,375 listings starting at $1,995
Used Mercury Mountaineer
29 Great Deals out of 1,182 listings starting at $2,300
Used Pontiac Grand Prix
30 Great Deals out of 2,730 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.