1984 Suburban 4x4 6.2l diesel. Simply cannot get both batteries to hold a charge. Used two separate battery chargers. With 2 batteries is there anything I need to do as if it only had one? Will jump

Asked by Sep 12, 2015 at 09:43 AM about the 1984 Chevrolet Suburban K10 4WD

Question type: Maintenance & Repair

Will jump start then runs fine. While
running, dashboard voltmeter shows 13
volts. Cannot find anything "turned on" that
I could shut off, but 4 nights ago when it
was fine, I left the inside dome lights on.
Oops. But should recharge?

1 Answer

1,435

i think you have one bad battery. you should go have them checked in order to check them you do have to take one cable off one of the battery's . also sad to say but if you do find one bad you need to replace both as a set.

Best Answer Mark helpful

Your Answer

Chevrolet Suburban Experts

  • #1
    Andrew Olsen
    Reputation
    1,030
  • #2
    Eric Fritz
    Reputation
    910
  • #3
    Neal Turner
    Reputation
    900
View All

Related Models For Sale

Used Ford F-150
2,304 Great Deals out of 183,573 listings starting at $699

Used Cars For Sale

2017 Chevrolet Suburban For Sale
56 Great Deals out of 11,163 listings starting at $42,430
2016 Chevrolet Suburban For Sale
50 Great Deals out of 1,363 listings starting at $35,875
2015 Chevrolet Suburban For Sale
25 Great Deals out of 1,334 listings starting at $22,995
2014 Chevrolet Suburban For Sale
16 Great Deals out of 514 listings starting at $18,995
2013 Chevrolet Suburban For Sale
19 Great Deals out of 545 listings starting at $13,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.