My 2003 crown Victoria will not go right into gear when it is cold, it acts like it is slow on fluid but the fluid level is full

Asked by Aug 29, 2015 at 04:54 PM about the 2003 Ford Crown Victoria Police Interceptor

Question type: Maintenance & Repair

1 Answer

18,570

Sounds like the transmission filter is clogged change fluid and filter.

Your Answer

Add photo

Related Questions

Search Ford Crown Victoria Questions

Ford Crown Victoria Experts

#1 Tracy Hooks
Tracy Hooks
Reputation 1,780
#2 Tom Demyan
Tom Demyan
Reputation 980
#3 tennisshoes
tennisshoes
Reputation 680
View All

Related Models For Sale

Used Mercury Grand Marquis
31 Great Deals out of 1,804 listings starting at $2,250
Used Lincoln Town Car
33 Great Deals out of 1,820 listings starting at $1,750
Used Chevrolet Impala
520 Great Deals out of 31,726 listings starting at $1,450
Used Ford Mustang
474 Great Deals out of 45,735 listings starting at $1,999
Used Ford Taurus
249 Great Deals out of 20,434 listings starting at $699
Used Ford F-150
2,191 Great Deals out of 206,316 listings starting at $1,499
Used Ford Explorer
944 Great Deals out of 72,519 listings starting at $1,000
Used Chevrolet Tahoe
548 Great Deals out of 29,234 listings starting at $1,699
Used Mercury Marauder
25 listings starting at $7,300
Used Honda Accord
812 Great Deals out of 84,287 listings starting at $1,050
Used Chevrolet Camaro
226 Great Deals out of 30,943 listings starting at $1,217

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.