2002 Buick LeSabre -Replaced MAF sensor and engine still stalls and stutters. What else should I check?

Asked by Nov 06, 2013 at 09:31 PM about the 2002 Buick LeSabre Limited Sedan FWD

Question type: Maintenance & Repair

2002 Buick LeSabre engine stuttered and stalled today. Disconnected MAF sensor and
engine runs without stalling. Replaced MAF sensor and reconnected cable. Engine still
stalls and stutters.  I had to disconnect the sensor again to drive home. What else should
I check?

2 Answers

1,505

The connector or the wiring harness could have corrosion or a short in it some where check the terminals on the plug for looseness and or corrosion follow it back to your ecm

675

Try disconnecting the battery for a few minutes and reconnect. It will reset the computer. I had the same problem with a Cadillac.

1 people found this helpful.

Your Answer

Buick LeSabre Experts

  • #1
    Tom Demyan
    Reputation
    2,420
  • #2
    John Saffrahn
    Reputation
    2,150
  • #3
    Austin Gaboda
    Reputation
    1,510
View All

Related Models For Sale

Used Buick Park Avenue
292 listings starting at $1,988
Used Chevrolet Impala
397 Great Deals out of 25,595 listings starting at $799
Used Buick Regal
82 Great Deals out of 4,088 listings starting at $3,995
Used Buick Century
570 listings starting at $1,200
Used Honda Accord
424 Great Deals out of 101,059 listings starting at $1,200
Used Toyota Camry
761 Great Deals out of 70,900 listings starting at $1,200
Used Chevrolet Malibu
480 Great Deals out of 49,315 listings starting at $2,000
Used Cadillac DeVille
1,272 listings starting at $1,988
Used Mercury Grand Marquis
19 Great Deals out of 1,192 listings starting at $1,200
Used Lincoln Town Car
24 Great Deals out of 1,358 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.